[SeaBIOS] [PATCH 00/10] Misc code cleanups

Kevin O'Connor kevin at koconnor.net
Fri Oct 9 19:53:28 CEST 2015


This series is a fallout of work I was doing to test PAE.  I think the
cleanups in this series make sense even without PAE.

-Kevin


Kevin O'Connor (10):
  e820: Introduce e820_remove() and avoid exporting E820_HOLE
  e820: Rename memmap.c to e820map.c and use consistent "e820_" prefix
  e820: Update debugging messages to report 64bit values
  virtio: Simplify vring alignment code
  virtio: Move standard definitions from virtio-ring.h to standard
    headers
  malloc: Use consistent naming for internal low-level "alloc" functions
  malloc: Introduce common helper alloc_new_detail()
  malloc: Add warning if free() called on invalid memory
  malloc: Don't mix virtual and physical addresses
  memmap: Introduce SYMBOL() macro to access linker script symbols

 Makefile                    |   2 +-
 src/biosvar.h               |   6 +-
 src/{memmap.c => e820map.c} |  18 ++-
 src/{memmap.h => e820map.h} |   9 +-
 src/fw/biostables.c         |  10 +-
 src/fw/coreboot.c           |   8 +-
 src/fw/csm.c                |  18 +--
 src/fw/paravirt.c           |  14 +--
 src/fw/pciinit.c            |   6 +-
 src/fw/shadow.c             |  10 +-
 src/fw/xen.c                |   9 +-
 src/hw/pvscsi.c             |   2 +-
 src/hw/ramdisk.c            |   5 +-
 src/hw/virtio-ring.h        |  36 ++----
 src/list.h                  |  10 ++
 src/malloc.c                | 294 +++++++++++++++++++++++---------------------
 src/malloc.h                |  11 +-
 src/memmap.h                |  38 +++---
 src/pmm.c                   |  16 +--
 src/post.c                  |  41 +++---
 src/system.c                |   2 +-
 src/x86.h                   |   8 ++
 22 files changed, 293 insertions(+), 280 deletions(-)
 rename src/{memmap.c => e820map.c} (90%)
 copy src/{memmap.h => e820map.h} (66%)

-- 
2.4.3




More information about the SeaBIOS mailing list