[SeaBIOS] [Qemu-devel] [PATCH v4 for-2.3 11/25] hw/apci: add _PRT method for extra PCI root busses

Marcel Apfelbaum marcel at redhat.com
Tue Mar 10 18:26:13 CET 2015


On 03/10/2015 07:07 PM, Michael S. Tsirkin wrote:
> On Sun, Mar 08, 2015 at 01:16:13PM +0200, Marcel Apfelbaum wrote:
>> Signed-off-by: Marcel Apfelbaum <marcel at redhat.com>
>> ---
>>   hw/i386/acpi-build.c | 65 ++++++++++++++++++++++++++++++++++++++++++++++++++++
>>   1 file changed, 65 insertions(+)
>>
>> diff --git a/hw/i386/acpi-build.c b/hw/i386/acpi-build.c
>> index e5709e8..e7a1a36 100644
>> --- a/hw/i386/acpi-build.c
>> +++ b/hw/i386/acpi-build.c
>> @@ -664,6 +664,70 @@ static void build_append_pci_bus_devices(Aml *parent_scope, PCIBus *bus,
>>       aml_append(parent_scope, method);
>>   }
>>
>> +static Aml *build_link(Aml *lnk, Aml *lnk_pkg, const char *link_name, int idx)
>
> Pls document arguments, and generally make this function
> more readable.
I'll think of something

>
>> +{
>> +    Aml *if_ctx, *pkg;
>> +
>> +    if_ctx = aml_if(aml_equal(lnk, aml_int(idx)));
>> +    pkg = aml_package(4);
>
> These assignments can be part of declarations.
OK

>
>> +    aml_append(pkg, aml_int(0));
>> +    aml_append(pkg, aml_int(0));
>> +    aml_append(pkg, aml_name(link_name, ""));
>
> this sould be aml_name(link_name) I think?
It doesn't work without the "" agument, works only for literals.
If you have any idea how to make it work, I'll be glad to change it.

>
>> +    aml_append(pkg, aml_int(0));
>> +    aml_append(if_ctx, aml_store(pkg, lnk_pkg));
>> +
>> +    return if_ctx;
>> +}
>> +
>> +static Aml *build_prt(void)
>> +{
>> +    Aml *method, *while_ctx, *pin, *slot, *lnk, *pkg, *res;
>> +
>> +    method = aml_method("_PRT", 0);
>> +    res = aml_local(0);
>> +    pin = aml_local(1);
>> +    slot = aml_local(2);
>> +    lnk = aml_local(3);
>> +    pkg = aml_local(4);
>> +
>> +    aml_append(method, aml_store(aml_package(128), res));
>> +    aml_append(method, aml_store(aml_int(0), pin));
>> +
>> +    /* while (pin < 128) */
>> +    while_ctx = aml_while(aml_lless(pin, aml_int(128)));
>> +    {
>> +        /* slot = pin >> 2 */
>> +        aml_append(while_ctx,
>> +                   aml_store(aml_shiftright(pin, aml_int(2)), slot));
>> +        /* lnk = (slot + pin) & 3 */
>> +        aml_append(while_ctx,
>> +                   aml_store(aml_and(aml_add(pin, slot), aml_int(3)), lnk));
>> +
>> +        /* pkg[2] = "LNK[A|B|C|D]", selection based on lnk % 3  */
>
> in fact pkg here is not same as pkg above, is it?
The same, but I can move the declaration to the while block.

Thanks,
Marcel

>
>> +        aml_append(while_ctx, build_link(lnk, pkg, "LNKD", 0));
>> +        aml_append(while_ctx, build_link(lnk, pkg, "LNKA", 1));
>> +        aml_append(while_ctx, build_link(lnk, pkg, "LNKB", 2));
>> +        aml_append(while_ctx, build_link(lnk, pkg, "LNKC", 3));
>> +
>> +        /* pkg[0] = 0x[slot]FFFF */
>> +        aml_append(while_ctx,
>> +            aml_store(aml_or(aml_shiftleft(slot, aml_int(16)), aml_int(0xFFFF)),
>> +                      aml_index(pkg, aml_int(0))));
>> +        /* pkg[1] = pin & 3 */
>> +        aml_append(while_ctx,
>> +            aml_store(aml_and(pin, aml_int(3)), aml_index(pkg, aml_int(1))));
>> +        /* res[pin] = pkg */
>> +        aml_append(while_ctx, aml_store(pkg, aml_index(res, pin)));
>> +        /* pin++ */
>> +        aml_append(while_ctx, aml_increment(pin));
>> +    }
>> +    aml_append(method, while_ctx);
>> +    /* return res*/
>> +    aml_append(method, aml_return(res));
>> +
>> +    return method;
>> +}
>> +
>>   static void
>>   build_ssdt(GArray *table_data, GArray *linker,
>>              AcpiCpuInfo *cpu, AcpiPmInfo *pm, AcpiMiscInfo *misc,
>> @@ -708,6 +772,7 @@ build_ssdt(GArray *table_data, GArray *linker,
>>               aml_append(dev, aml_name_decl("_HID", aml_string("PNP0A03")));
>>               aml_append(dev,
>>                   aml_name_decl("_BBN", aml_int((uint8_t)bus_info->bus)));
>> +            aml_append(dev, build_prt());
>>               aml_append(scope, dev);
>>               aml_append(ssdt, scope);
>>           }
>> --
>> 2.1.0




More information about the SeaBIOS mailing list