[SeaBIOS] [coreboot] serial console : no keystroke

Kyösti Mälkki kyosti.malkki at gmail.com
Thu Aug 20 11:54:43 CET 2015

On to, 2015-08-13 at 15:47 +0200, Maxime de Roucy wrote:
> Hello,
> I am trying vanilla coreboot/SeaBios on an pc-engines apu1d4 :
> http://www.pcengines.ch/apu1d4.htm
> The board natively use a modified version of coreboot, the sources are
> available at http://www.pcengines.ch/howto.php#CoreBoot (coreboot_14090
> 8.tar.gz)
> I use a usb-SR232 adapter to connect on the board.
> I use minicom and picocom. Both are working fine.
> When I use coreboot vanilla (master) with SeaBios vanilla (master, I
> also tried 1.7.5), when I get to "Press ESC for boot menu" I can't send
> keystroke to SeaBios through the serial console.
> I have to plug an USB keyboard and press ESC on it.

Look for uart_check_keystrokes() under seabios tree of the tarball you
referenced. You are asking for an extended capability Sage has added to
'SageBIOS' and this feature is not available in upstream SeaBIOS tree.
Should be fairly straighforward to upstream that, as it appears to be
all the conditional code under CONFIG_INT16_SERIAL_KEYBOARD.

SageBIOS payload extracted from original apu1 firmware might work with
keyboard interaction on serial, I don't remember if I ever tried it.
Do it this way, and you lack any SeaBIOS updates from last 18 or so

Unfortunately many changes Sage has developed for SageBIOS have never
been offered upstream SeaBIOS as patches at all, and the available
tarballs of released SageBIOS tree seem to be missing half the toolchain
(Makefiles, Kconfigs) to "kindly direct" you to use Sage EDK eclipse

The feature to use frontpanel switch on apu1d to reset SageBIOS
bootorder file has not been upstreamed either. In addition to the
SeaBIOS change, this introduced and exposed new CBMEM table entries from
coreboot proper to payloads in a way that might not pass coreboot QA and
review. I quess I could try what the response is. 


More information about the SeaBIOS mailing list