[SeaBIOS] [HELP] The program cause screen mess

eJim Lee lyjforjob at gmail.com
Tue Apr 21 17:36:54 CEST 2015

I tried QEMU - 2.3.0-rc4 and used the seabios and seavgabios from
qemu. The qemu command line:
./build/x86_64-softmmu/qemu-system-x86_64 -chardev stdio,id=seabios
-device isa-debugcon,iobase=0x402,chardev=seabios -m 512 -enable-kvm
-hda tmp/xp.append -hdb tmp/data.append
I sure the bug was repeated when I used "WinXP SP3 with Chinese".

But I installed a new XP with English using the command line above and
found that bug disappear.
So you couldn't repeat this bug.

What do you have any idea? I can't understand why vgabios wasn't used
and lead to screen mess.
The global variable area and code section have been overlap? I lack
knowledge about vgabios.

eJim Lee

2015-04-21 2:49 GMT+08:00 Kevin O'Connor <kevin at koconnor.net>:
> On Mon, Apr 20, 2015 at 02:46:03PM -0400, Kevin O'Connor wrote:
>> On Tue, Apr 21, 2015 at 01:57:53AM +0800, eJim Lee wrote:
>> > 2015-04-21 0:45 GMT+08:00 Kevin O'Connor <kevin at koconnor.net>:
>> > > On Tue, Apr 21, 2015 at 12:23:15AM +0800, eJim Lee wrote:
>> > >> Kevin, did you repeat screen mess?
>> > >
>> > > I've tried several different configurations (including the last
>> > > command line you sent), but I have not been able to reproduce any
>> > > screen corruption.
>> >
>> > I have repeated it at every time on server, my laptop or my pc.
>> > I tried it on ubuntu 14.04, centos 6.5, kernel 3.10.67 and kernel. etc.
>> > What is the difference? I used guest os is xp sp3. What yours?
>> > I will try again with environment same as yours.
>> I'm using "Windows XP professional - Service Pack 3".
>> To simplify versions, can you use the latest QEMU - 2.3.0-rc4 and use
>> the seabios and seavgabios that come with that version of qemu.  I
>> tested that here and don't see corruption with those versions.  This
>> is the command line I used:
>> ../qemu/qemu-git/x86_64-softmmu/qemu-system-x86_64 -chardev stdio,id=seabios -device isa-debugcon,iobase=0x402,chardev=seabios -m 512 -hda winxp-test-wbc -enable-kvm
> Also, for completeness, try it without kvm as well:
> ../qemu/qemu-git/x86_64-softmmu/qemu-system-x86_64 -chardev stdio,id=seabios -device isa-debugcon,iobase=0x402,chardev=seabios -m 512 -hda winxp-test-wbc
> -Kevin

More information about the SeaBIOS mailing list