[SeaBIOS] [coreboot] [solved] i945: AHCI timeout with Crucial m4 SSD 2.5 in SeaBIOS on cold boot

Paul Menzel paulepanter at users.sourceforge.net
Sat Oct 4 17:34:21 CEST 2014

Am Freitag, den 19.09.2014, 11:47 -0400 schrieb Kevin O'Connor:
> On Fri, Sep 19, 2014 at 09:36:30AM +0200, Paul Menzel wrote:
> >         01.542: init ahci
> >         01.541: AHCI controller at 1f.2, iobase e4444400, irq 0
> >         01.541: AHCI: cap 0xdf12ff03, ports_impl 0x1
> >         01.541: /7f673000\ Start thread
> >         01.541: |7f673000| AHCI/0: probing
> >         01.542: |7f673000| AHCI/0: link up
> >         […]
> >         32.700: |7f673000| WARNING - Timeout at ahci_port_setup:466!
> >         32.700: |7f673000| AHCI/0: device not ready (tf 0x80 cmd=6016 stat=113 ctl=0 err=4050002)
> The err field indicates the controller thinks the device disconnected
> and then reconnected.  Possibly the firmware on the ssd was resetting
> itself (or something similar).
> Can you see if a more recent firmware version is available for your
> SSD?

Upgrading the firmware from 0309 to 070H seems to have fixed the issue.
The drive is now detected on cold boot.

> Otherwise, it looks like this could be worked around in SeaBIOS,
> but it wouldn't be particularly nice.

Some message on the screen informing the user about a bad device could
be helpful, though currently the Crucial m4 is the only device, this is
needed for.

        One or several attached drives could not be correctly
        initialized. This could be a problem with the hardware or the
        drive firmware. Please check the hardware on a different system
        or update the firmware and try again.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 181 bytes
Desc: This is a digitally signed message part
URL: <http://www.seabios.org/pipermail/seabios/attachments/20141004/97ef537b/attachment.asc>

More information about the SeaBIOS mailing list