[SeaBIOS] seavgabios resolutions, win8

Michael Tokarev mjt at tls.msk.ru
Fri Nov 29 16:59:25 CET 2013

29.11.2013 19:23, Gerd Hoffmann wrote:
>   Hi,
>> +    { 0x18d, { MM_DIRECT, 1920, 1080, 16, 8, 16, SEG_GRAPH } },
>> +    { 0x18e, { MM_DIRECT, 1920, 1080, 24, 8, 16, SEG_GRAPH } },
>> +    { 0x18f, { MM_DIRECT, 1920, 1080, 32, 8, 16, SEG_GRAPH } },
>> I'm not sure I understand how list of modes is maintained/used in
>> seavgabios.  The above patch at least allows one of the very common
>> modes to be selected in windows clients.
> Just get-send-email a proper patch to the seabios list.

It isn't about patch submission.  It is about _writing_ the patch, --
I mentioned that there are a few other modes which are requested by
users, and also - which I didn't mention - I don't know which mode
identifiers to use, -- does it matter which IDs to use?  In the above
example, added modes are 0x18[def], does it matter?

>> And while at it, there's another bugreport against vgabios package in
>> Debian, see http://bugs.debian.org/685097 .  It looks like windows8
>> isn't happy with vgabios-provided modes and does not let to change
>> resolution at all, sticking at 1024x768.  That bugreport points to
>> a patchset, http://lists.xen.org/archives/html/xen-devel/2012-05/msg00260.html
>> (this is just one patch from it), which has been applied to xen copy
>> of vgabios to solve exactly this issue with win8, and reportedly it
>> works there.  It looks like something similar should be done in
>> seavgabios too, since with it, win8 guest is also stuck at the same
>> resolution.
> Hmm, last time I tried resolution switching in win8 worked just fine
> with seavgabios.  Can you double-check?

I just installed a fresh win8 VM, and it is indeed stuck with 1024x768,
with the "screen resolution" combo-box grayed out in the appropriate
control panel screen, -- there's no way to choose any other resolution.

However I'm not sure whenever this is because of some (vga)bios issue
or because of the lack of my windows8 activation (I activated it in
qemu-1.1 and it works fine there, but it immediately becomes "not
activated" with any later version of qemu, despite the usage of
-M pc-1.1) -- reportedly, win8 has some restrictions in display area
when not activated, but I don't know details.  I'd expect it to block
the "themes/personalization" part, not screen resolution part...

I'll try to get hold of win8.1, maybe there things are a bit different...



More information about the SeaBIOS mailing list