[SeaBIOS] SeaVGABIOS crash on FC13 X11

Julian Pidancet julian.pidancet at gmail.com
Sun Mar 10 02:09:35 CET 2013

On Sun, Mar 10, 2013 at 12:09 AM, Kevin O'Connor <kevin at koconnor.net> wrote:
> Julian - I know you played with SeaVGABIOS and X11 a bit a year or so
> ago.  Any thoughts on what is happening?

Hi Kevin,

I have not really followed the latest developments on SeaBIOS, so I'm
not sure I'll be very useful. But I can try to take a look at it.
I seem to remember that qemu uses SeaVGABIOS now. If I try to compile
a recent qemu and launch the fedora liveCD, will it exhibit the issue

The last time I investigated on an issue with SeaVGABIOS and X11, it
was because the 16bit code emulator of X11 wasn't handling properly
certain prefixed instructions. I think we worked around the issue by
post-processing the assembly output of the compilation to replace the
problematic instructions with non-prefixed instructions.

I also tried to send several times a patch on the Xorg mailing list to
address that issue, but never managed to attract anyone's attention.
It could be useful if someone volunteered to try sending them again.

According to the backtrace you sent, the crash seems to be located in
the libint10 module. The issue I worked on was in "x86emu". I'm not
sure how these two parts relate to each other, but we could well be
facing something very similar.

The first think I would try, is to check in the vga bios assembly and
make sure we're correctly replacing all of the "sensitive" prefixed
x86 instructions. Some new form of one of these instruction may have
made it's way in the VGA rom code.


More information about the SeaBIOS mailing list