[SeaBIOS] [Qemu-devel] problems with freeBSD

Aurelien Jarno aurelien at aurel32.net
Thu Mar 7 17:15:24 CET 2013

On Thu, Mar 07, 2013 at 08:57:06AM -0500, Kevin O'Connor wrote:
> On Thu, Mar 07, 2013 at 09:43:04AM +0100, Aurelien Jarno wrote:
> > On Wed, Mar 06, 2013 at 07:53:51PM -0500, Kevin O'Connor wrote:
> > > That change is definitely just build related - I don't see how it
> > > could impact the final SeaBIOS binary.  How did you conclude that this
> > > commit is what fixes the issue?
> > > 
> > 
> > I did a git bisect to find the commit fixing the issue. Then, as I was
> > not believing the result, I tried the following sequence a dozen of
> > times (for some unknown reasons the FreeBSD install CD doesn't exhibit
> > the issue, so I used the Debian GNU/kFreeBSD installer):
> Thanks.  I'll take a look at this tonight.  If you get a chance first,
> could you try adding "make distclean; make clean" into the seabios
> steps?

It doesn't change anything (which is more or less expected due to the
git clean -fdx). I have tried to also copy acpi-dsdt.aml and it doesn't
help (the file is the same in qemu v1.4.0, and in the "bad" and "good"
version of seabios).

Aurelien Jarno                          GPG: 1024D/F1BCDB73
aurelien at aurel32.net                 http://www.aurel32.net

More information about the SeaBIOS mailing list