[openfirmware] Troubleshooting VGA under qemu?

Marcin Cieslak saper at saper.info
Thu Oct 1 10:49:23 CET 2015

On Thu, 1 Oct 2015, James Cameron wrote:

> >  -vga vmware -> VMWare (15ad:404) - DOES NOT WORK
> For me, "-vga vmware" reproduces your problem.

> My guess is something wrong with register mapping ... or the driver
> shouldn't be tried twice.  Next step might be to increase the delay
> for the stand-init interrupt key 'i' ... which I've been unable to
> trigger.  I'm also not sure how to apply the debugger to an FCode
> driver that isn't loaded yet, but that would be a learning exercise.
> ;-)

This was easy - changing "key?" in fw.fth to "true" and commenting
out the delay - it just sits there and waits (for 'i' or otherwise).

Fortunately I could just "dev /pci" and "debug assign-all-addresses"
and then just resume. In the end I have just added "debug-me"
there. Forth Lesson #15! Fantastic tutorial.

The problem is that vwvga driver does not have a "reg" property
describing its BARs. Not sure when (or how?) it ever worked.

Maybe we should add a warning (with diag-switch? true or otherwise:

--- dev/pcibus.fth  (wersja 3784)
+++ dev/pcibus.fth  (kopia robocza)
@@ -1183,7 +1183,8 @@
             4                                               ( increment )
          then                                               ( increment )
+   else
+      " reg property missing!" diag-type-cr
    r> finish-aa-property


More information about the openfirmware mailing list