[openfirmware] Building OpenFirmware svn rev 795

Robert Davidson rdavidson at obsidian.com.au
Thu Sep 25 08:37:28 CEST 2008

Hi all,

I'm hoping someone can tell me whats wrong or why I can't build
OpenFirmware rev 795.

I'm trying to follow the instructions at
http://www.openfirmware.info/Open_Firmware#Build_Open_Firmware but
they're not working.  I keep getting errors when running 'make'.

I have tried modifying the configuration as the above site suggests, and
I've also tried without making any changes at all, both fail with the
same error at the same place.

My primary goal right now is to simply play with coreboot and
OpenFirmware in qemu, then I might consider trying it on some real hardware.

Any help is appreciated.

make[1]: Entering directory `/usr/src/coreboot/build-qemu/openfirmware/cpu/x86/Linux'
cc -c -O -g -m32 -DTARGET_X86 ../../../forth/wrapper/wrapper.c -o wrapper.o
cc -c -O -g -m32 -DTARGET_X86 ../../../forth/wrapper/logger.c -o logger.o
cc -c -O -g -m32 -DTARGET_X86 -I../../../forth/wrapper/zip ../../../forth/wrapper/zip/zipmem.c -o zipmem.o
cc -c -O -g -m32 -DTARGET_X86 -I../../../forth/wrapper/zip ../../../forth/wrapper/zip/deflate.c -o deflate.o
cc -c -O -g -m32 -DTARGET_X86 -I../../../forth/wrapper/zip ../../../forth/wrapper/zip/trees.c -o trees.o
cc -c -O -g -m32 -DTARGET_X86 -I../../../forth/wrapper/zip ../../../forth/wrapper/zip/bits.c -o bits.o
cc -c -O -g -m32 -DTARGET_X86 -I../../../forth/wrapper/zip ../../../forth/wrapper/zip/util.c -o util.o
cc -c -m32 -O0 -fpic ../../../forth/wrapper/zip/inflate.c -o inflate.o
cc -m32 -o forth wrapper.o logger.o zipmem.o deflate.o trees.o bits.o util.o inflate.o
make[1]: Leaving directory `/usr/src/coreboot/build-qemu/openfirmware/cpu/x86/Linux'
make[1]: Entering directory `/usr/src/coreboot/build-qemu/openfirmware/cpu/x86/build'
make -C ../Linux ../build/inflate.bin
make[2]: Entering directory `/usr/src/coreboot/build-qemu/openfirmware/cpu/x86/Linux'
objcopy -O binary inflate.o ../build/inflate.bin
make[2]: Leaving directory `/usr/src/coreboot/build-qemu/openfirmware/cpu/x86/Linux'
make[1]: Leaving directory `/usr/src/coreboot/build-qemu/openfirmware/cpu/x86/build'
./build ofw.c32
--- Rebuilding reset.di
--- Cmd: ${HOSTDIR}/forth ${HOSTDIR}/../build/builder.dic ../reset.bth
--- Rebuilding start.di
--- Cmd: ${HOSTDIR}/forth ${HOSTDIR}/../build/builder.dic ../start.bth
--- Rebuilding kernel.dic
--- Cmd: ${HOSTDIR}/forth ${HOSTDIR}/../build/builder.dic ../kernel.bth
--- Saving kernel.dic ---
--- Rebuilding tools.dic
--- Cmd: ${HOSTDIR}/x86forth ${BP}/cpu/x86/build/kernel.dic ../tools.bth
--- Saving tools.dic ---
--- Rebuilding basefw.dic
--- Cmd: ${HOSTDIR}/x86forth ${BP}/cpu/x86/build/tools.dic ../basefw.bth

--- Saving basefw.dic ---
--- Rebuilding bootsec.hex
--- Cmd: ${HOSTDIR}/forth ${HOSTDIR}/../build/builder.dic ../bootsec.bth
1fe 1f0
400 400
--- Rebuilding fw.img
--- Cmd: ${HOSTDIR}/x86forth ${BP}/cpu/x86/build/basefw.dic ../fw.bth

${BP}/cpu/x86/pc/biosload/rmenter.fth:152: >off ?
make: *** [ofw.c32] Error 1

Robert Davidson.
Obsidian Consulting Group.
Ph. 03-9355-7844
E-Mail: support at obsidian.com.au

More information about the openfirmware mailing list