[OpenBIOS] [Qemu-devel] [Qemu-ppc] CUDA has problems with Mac OS 10.4

Alfonso Gamboa gtxent at gmail.com
Tue Nov 24 09:38:19 CET 2015

On Tue, Nov 24, 2015 at 12:01 AM, Mark Cave-Ayland <
mark.cave-ayland at ilande.co.uk> wrote:

> On 24/11/15 03:28, Programmingkid wrote:
> >> I've just done some testing here on my 9.2.2 ISO and I've found the
> >> following:
> >>
> >> - Removing "Apple Audio Extension" appears to prevent some kind of
> >> corruption which allows MacsBugs to give non-corrupt stack traces
> >>
> >> - The resulting stack trace points at "AINI 8042 05AE Startup ASLM PPC"
> >>
> >> - Further removing "Open Transport ASLM Modules" allows boot to proceed
> >> nearly all the way except for a hang just before the progress bar
> >> reaches the end
> >>
> >> - Finally removing "Multiprocessing" allows boot to proceed all the way
> >> to the desktop
> >>
> >> Alfonso/John can you confirm whether removing these 3 extensions works
> >> for your images too? If you are able to run the OS 9 installer all the
> >> way through and manually mount the hd images to remove them by hand
> >> before the next boot, do you end up with a bootable OS 9 HD image?
> >
> > Which version of Macsbug are you using? Do you have an 9.2.2 image file
> > available for download that has macsbug installed? I tried installing
> Macsbug
> > 6.6.3 into my iso file, but Mac OS 9 always stops booting right before
> the debugger
> > message is suppose to appear.
> One other thing I forgot to mention: if you install MacsBugs onto your
> ISO, you need to provide some mouse or keyboard input around the time
> when the happy mac icon appears (I normally capture the mouse and move
> it around a little), otherwise as you mention you see a freeze just
> before "Debugger Installed" appears.
> My guess is that MacsBugs is trying to work out whether to use ADB or
> USB for keyboard, so unless the OS 9 ADB driver gets any input then it
> can't decide and hangs on boot. Then again this could be another bug
> somewhere in the QEMU ADB emulation...
> ATB,
> Mark.

You are correct about booting MacsBug and mouse or keyboard input during
happy mac icon!  Also, Programmingkid, you hit the nail on the head
regarding those extensions.  Removing those 4 extensions and
Multiprocessing Folder does indeed allow boot to desktop.

In my testing tonight, I was able to successfully patch the System file to
allow the System Folder from the installation cd to boot off the hard disk
image, before it was throwing an error after happy mac icon saying the
media had been copied and would not boot.  I achieved this by editing the
System file and removing the resource "xboo". This resource apparently
checks whether the boot volume is a locked HFS volume or not, and denies
boot accordingly.

I have included MacsBug 6.6.3 in the System Folder, and right before I get
to desktop, MacsBug opens with a "PowerPC Illegal Instruction at 00000000",
but I am able to type ES (escape to shell) to successfully boot into the

Next, when running either the 9.2.1 OR 9.2.2 installer, MacsBug throws,
"PowerPC unmapped memory exception at AAFE0700".  I am then able to escape
to shell and resume the Finder.  I have tried copying the installer to
another disk image, increase memory allocation, to no avail.  The same
error persists.

I was also unable to find a method to boot any installed System File.  I
attempted to use an existing 9.2.2 System Folder found on macintoshgarden,
which would crash QEMU completely.  Next, extracting the "Big System
Morsels" file from the 9.2.2 installation cd (which should be the System
file, just renamed and with a different creator code) and setting the
Creator and Type Codes, throwing it in the System Folder and rebooting,
results in an Illegal Instruction and or Bus Error during boot.

Seems we still have some work to do...

I'm uploading a disk image y'all can use to boot to OS9.2.2CDSYSTEM for
further testing, I will forward the link when its ready to download.

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.openfirmware.info/pipermail/openbios/attachments/20151124/5fe2a81f/attachment.html>

More information about the OpenBIOS mailing list