[OpenBIOS] sparc32 openbios - passing nvram options

Dmitriy Kargapolov dmitriy.kargapolov at gmail.com
Sun Sep 12 18:28:50 CEST 2010

On Sat, Sep 11, 2010 at 3:08 AM, Blue Swirl <blauwirbel at gmail.com> wrote:

> On Sat, Sep 11, 2010 at 3:39 AM, Dmitriy Kargapolov
> <dmitriy.kargapolov at gmail.com> wrote:
> > Hello,
> > I tried to install netbsd 5.0.2 to qemu-system-sparc (which uses
> openbios).
> > Boot from cdrom image and installation passed with no problems.
> > But I was not able to boot from hdd. All the -boot, -prom-env options
> kind
> > of ignored by qemu-system-sparc...
> > All tries end up with booting fromn cdrom (if presented).
> >
> > Configuration device id QEMU version 1 machine id 64
> > UUID: 00000000-0000-0000-0000-000000000000
> > CPUs: 1 x TI,TMS390Z55
> > invalid nvram partition length
> > nvram error detected, zapping pram
> This looks like a very old version. Please use a recent one like SVN
> HEAD, or the one shipped with QEMU (currently r859 in git HEAD).
> Yes, I see Fedora-based packages (which I tried to use) are too old.
To compile openbios from the repo I need sparc cross-compiler, -binutils,
I found no precompiled cross-tools for sparc in Fedora...
What would be your recommendation regarding cross-tools version, what do you
use to compile openbios and on what host platform?
Thank you.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openbios.org/pipermail/openbios/attachments/20100912/9b71622a/attachment.html>

More information about the OpenBIOS mailing list