[OpenBIOS] ppc(64) debugging

Mark Cave-Ayland mark.cave-ayland at siriusit.co.uk
Mon Nov 1 12:01:48 CET 2010

Andreas Färber wrote:

> I'm trying to find out how far we get with the ppc64 OpenBIOS, so I've 
> tried the following:
> $ .../ppc64-softmmu/qemu-system-ppc64 ... -nographic -prom-env 
> 'auto-boot?=false' -s -S
> $ gdb --arch=ppc64
> GNU gdb 6.3.50-20050815 (Apple version gdb-967) (Tue Jul 14 02:15:14 UTC 
> 2009)
> Copyright 2004 Free Software Foundation, Inc.
> GDB is free software, covered by the GNU General Public License, and you 
> are
> welcome to change it and/or distribute copies of it under certain 
> conditions.
> Type "show copying" to see the conditions.
> There is absolutely no warranty for GDB.  Type "show warranty" for details.
> This GDB was configured as "powerpc-apple-darwin".
> (gdb) target remote localhost:1234
> Remote debugging using localhost:1234
> [New thread 1]
> 0x0000000000000000 in ?? ()
> (gdb) b *0xfffffffc
> Breakpoint 1 at 0xfffffffc
> (gdb) c
> Continuing.
> It doesn't break though and executes to the OpenBIOS prompt.
> 0xfffffffc is supposed to be the hard reset vector, i.e. the very first 
> instruction it must execute to branch to _entry.
> Any suggestions?

FWIW I had a problem with SPARC64 crashing gdb when I tried to step 
through the initialisation, and in the end I found out that everyone 
worked once the MMU had been initialised. So I ended up putting a new 
label into entry.S just after the MMU had been enabled and breaking 
there, at which point everything seemed to behave.



Mark Cave-Ayland - Senior Technical Architect
PostgreSQL - PostGIS
Sirius Corporation plc - control through freedom
t: +44 870 608 0063

Sirius Labs: http://www.siriusit.co.uk/labs

More information about the OpenBIOS mailing list