[OpenBIOS] Sparc64 OpenBIOS

Nick Couchman Nick.Couchman at seakr.com
Sun Nov 15 16:10:27 CET 2009

>>> On 2009/11/14 at 12:33, Tarl Neustaedter <Tarl.Neustaedter at Sun.COM> wrote:
> Nick Couchman wrote:
>> I have a pretty old version of the Solaris Nevada code that I tried to boot, 
> and I got a different error: open isn't unique.  I'll post actual output here 
> in a little while.
> Hmm. That's interesting. I wonder if we're getting a conflict between 
> packages in openbios and what the boot blocks are creating. You might 
> find it easier to debug the Solaris Nevada version, depending on just 
> how old it is. Among other things, under OpenSolaris you can find the 
> code for the boot blocks (which changed drastically from Solaris 10 to 
> Nevada), so you aren't quite struggling in the dark.
> Also, the Nevada version of the bootblocks responds to the "-H" 
> argument, indicating that after loading the filesystem into /packages, 
> it returns to the OK prompt rather than immediately trying to do the 
> boot itself. That lets you set up breakpoints in the filesystem code 
> before executing them.

I grabbed the newest Nevada ISO (b127) and tried to boot off that - the error is the same as Solaris 10:

0 > boot cdrom 
[sparc64] Booting file 'cdrom' with parameters ''
Not a bootable ELF image
Not a Linux kernel image
Not a bootable a.out image
Loading FCode image...
Loaded 7120 bytes
entry point is 0x4000
Evaluating FCode...

seek failed

Can't mount root

byte-load: exception caught!

I also tried the "boot -H" option and I get the following:
0 > boot -H cdrom 
[sparc64] Booting file '-H' with parameters 'cdrom'

I assume this is the point where I really need the debugger and the breakpoints so that I can step through the rest of the boot process piece-by-piece.


>> I'm pretty new to Qemu and OpenBIOS - what's the best way to go about 
> debugging this?  GDB?  Qemu's built-in debugging?
> Probably best to wait for the forth debugger that is being discussed. 
> Without breakpoints, you need to basically patch in breakpoints, which 
> is doable but time-consuming.

This e-mail may contain confidential and privileged material for the sole use of the intended recipient.  If this email is not intended for you, or you are not responsible for the delivery of this message to the intended recipient, please note that this message may contain SEAKR Engineering (SEAKR) Privileged/Proprietary Information.  In such a case, you are strictly prohibited from downloading, photocopying, distributing or otherwise using this message, its contents or attachments in any way.  If you have received this message in error, please notify us immediately by replying to this e-mail and delete the message from your mailbox.  Information contained in this message that does not relate to the business of SEAKR is neither endorsed by nor attributable to SEAKR.

More information about the OpenBIOS mailing list