[OpenBIOS] openfirmware entrypoint on i386

jakllsch at kollasch.net jakllsch at kollasch.net
Mon Jan 28 03:21:23 CET 2008


I've been exploring OpenFirmware on x86, under qemu with coreboot.

I've been trying to run the hello.elf example.  I have trouble
loading it from an ext2 file system, I get an message:

ok report-disk
ok boot /pci/pci-ide at 1,1/ide at 0/disk at 0:\hello.elf
Boot device: /pci/pci-ide at 1,1/ide at 0/disk at 0:\hello.elf  Arguments: root=/dev/ram0 mount_ramdisk=1
Unimplemented package interface procedure
Undefined word encountered 

I also tried using using qemu's -option-rom function
to throw a raw binary into the address space that i
could then place in memory with 'cmove' and then
tried to 'branch' or 'execute' it.
This method probably isn't worth pursuing much,
even thought it did get me the furthest.

The problem there was that the pointer to the
openfirmware interface function wasn't getting
passed in %eax, but then again, I wasn't using 'boot'.

Anyway, tips on this would be appreciated.

	Jonathan Kollasch
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: not available
Url : http://lists.openbios.org/pipermail/openbios/attachments/20080127/402c795d/attachment.sig 

More information about the OpenBIOS mailing list