[OpenBIOS] SILO loads Linux

Blue Swirl blueswir1 at hotmail.com
Mon May 15 21:29:48 CEST 2006

Today I got SILO to load Linux from CD, aliasing sd(x,y,z). I also made the 
boot less noisy by default. SILO file is given as hda, cd image as hdb:

3 > boot disk
[sparc] Booting file 'disk' with parameters '<NULL>'
Unknown filesystem type
Not a bootable ELF image
Unknown filesystem type
Not a Linux kernel image
Unknown filesystem type
Loading a.out image...
Loaded 96912 bytes
entry point is 0x4000
Jumping to entry point...
No config file loaded, you can boot just from this command line
Type [prompath;]part/path_to_image [parameters] on the prompt
E.g. /iommu/sbus/espdma/esp/sd at 3,0;4/vmlinux root=/dev/sda4
or 2/vmlinux.live (to load vmlinux.live from 2nd partition of boot disk)

Your imagename `:d' and arguments `' have either wrong syntax,
or describe a label which is not present in silo.conf
Type `help' at the boot: prompt if you need it and then try again.
boot: sd(0,1,0)/boot/sparc32.gz
Unknown filesystem type
Uncompressing image...
PROMLIB: obio_ranges 1

SILO can browse the filesystem, load sparc32.gz, uncompress it and start 
Linux. Linux fails as before.

I feel that if partition access worked, booting directly from disk would be 
easy. CD support needs some block size confusion solved, maybe even in Qemu. 
What is the syntax used for accessing partitions, is it not like 
.../sd at 0,0:a for first partition?

FREE pop-up blocking with the new MSN Toolbar - get it now! 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: openbios.patch-12.bz2
Type: application/octet-stream
Size: 3944 bytes
Desc: not available
Url : http://lists.openbios.org/pipermail/openbios/attachments/20060515/413144e6/openbios.patch-12.obj

More information about the OpenBIOS mailing list