[flashrom] Compiling from source on Chromebook:GalliumOS - can't get libusb?

Nico Huber nico.h at gmx.de
Sat Nov 4 12:21:17 CET 2017

Hi Anders,

On 03.11.2017 21:35, Anders Nelson wrote:
> Hi guys,
> Here's the error I get trying to apply the patch:
> "root at chrx:/home/chrx/Github/flashrom# git apply --check
> /home/chrx/Downloads/ich_descriptors-amd64.patch
> error: patch failed: ich_descriptors.c:1064
> error: ich_descriptors.c: patch does not apply"

sorry, I was looking at the wrong version of the code. Doesn't matter,
see below.

> Derp? Here's my output from "cc -v":
> ...
> And here's the output from the second command you asked for:
> "root at chrx:/home/chrx/Github/flashrom# cc -dM -E - < /dev/null
> ...
> #define __x86_64__ 1
> ...
> #define __amd64__ 1
> ...

Both are there that's fine. And I think now, that my original assumption
that this could be an issue was wrong: We do check for x86 not only in
the Makefile but also in ichspi.c too (pretty weird redundancy) and the
latter check is in sync with ich_descriptors.c.

I've also tried to build flashrom on Ubuntu 16.04 with the same compiler
version... and it worked *shrug*.

> Whaaatsa goin' onnn? Thanks for your help!

No clue, actually. Did you already try to build with `make
CONFIG_INTERNAL=no`? Just want to know, that this doesn't stall
your work. We are ofc very interested to understand and fix the
actual problem.

Can you please send us a copy of the `ichspi.o` and `ich_descriptors.o`
of the failing build.

Did you change anything in the code? or tried to build different
versions? switch branches? in case, you could try a `make clean`
(although, I can't imagine why it would be necessary).

Oh, I nearly forgot: Please show us the output of `git describe` (I'm
loosing track of our branches atm).


More information about the flashrom mailing list