[flashrom] Broadwell-DE SoC

Nico Huber nico.huber at secunet.com
Tue Aug 2 14:02:32 CEST 2016

Hi Wen,

On 01.08.2016 21:29, Wen Wang wrote:
> Has anybody tried flashrom on Broadwell-DE SoC? Intel has upstreamed
> coreboot support. But we are having trouble with flashrom. The ME region
> does not seem to be accessible.  We cannot read the entire flash (fails when
> reading ME) even though we enabled all reads in Master Access Section in
> FITC. We also tried to set FDO, it did not help either.
Your problem doesn't look related to an ME section lock. The address
where flashrom fails:
> Timeout error between offset 0x00014400 and 0x0001443f (= 0x00014400 + 63)!
resides already inside the ME region. So it looks to me as if flashrom
succeeds in reading the start of the ME region.

Sadly your log looks incomplete, did you miss to capture stderr? You can
also save the whole log to a file with the -o parameter.

> We would like to at least be able to update the BIOS region. However,
> flashrom performs a full read prior to doing partial write.
As told above, I don't think that this is your issue. Anyway this fea-
ture has been requested for a long time and there have been different
approaches to implement it in flashrom. Unfortunately, nothing has been
merged yet. Patches can be found in patchwork:
My work on that matter seems to be the most current but also most
invasive. It's the 14 patches from 2016-05-04.


More information about the flashrom mailing list