[flashrom] [PATCH 0/6] layout patches 4.0

Stefan Tauner stefan.tauner at student.tuwien.ac.at
Tue Sep 24 01:14:00 CEST 2013


Implementation of unquote_string() combining ideas from CD and myself.
Refined parser, new support for top-aligned address and flags.

And the last patch is open for discussion... it tests readability and
size of the --include files while parsing it and before actually reading
them (which only happens after a full chip read).

It is obviously useful for slow programmers because it can bail out
early when there are obvious problems with the file, but it is still
quite some overhead and it feels rather dumb to check this twice.
Maybe we should already read them in early instead of just checking?
The disadvantage is that we would need to allocate extra buffers for
them. The late read writes directly to newcontents and hence does not
need an extra buffer.

Stefan Tauner (6):
  Introduce helpers.c and unquote_string().
  layout: Add -i <region>[:<file>] support.
  layout: Better file parsing.
  layout: Add support for top-aligned addresses.
  layout: Add preliminary support for flags.
  [WIP] layout: Bailout early in process_include_args() if region file
    is inaccessible.

 Makefile                        |   2 +-
 cli_classic.c                   |   9 +-
 dummyflasher.c                  |   2 +-
 flash.h                         |   5 +-
 flashrom.8.tmpl                 | 139 +++++++-----
 flashrom.c                      |  18 +-
 helpers.c                       |  88 ++++++++
 layout.c                        | 478 +++++++++++++++++++++++++++++++++-------
 util/convert_layout_v1_to_v2.sh |  79 +++++++
 9 files changed, 683 insertions(+), 137 deletions(-)
 create mode 100644 helpers.c
 create mode 100755 util/convert_layout_v1_to_v2.sh

-- 
Kind regards, Stefan Tauner





More information about the flashrom mailing list