[flashrom] Bricked an Asus Pundit P1-AH1 barebones desktop system

Jason M. jason__m at yahoo.com
Fri Nov 1 23:28:41 CET 2013

Dear flashrom,

I just managed to brick my nice little Asus Pundit P1-AH1 barebones desktop system.

While researching for this e-mail, I figured out what happened:

I grabbed the updated BIOS from Asus' web site for P1-PH1, rather than P1-AH1.  Apparently, I believed Google's search results when they sent me to Asus' web site for AH1, but this time I noted the model discrepancy and did not get back the same BIOSes when I changed to the correct model.

Knowing Asus, the PH1 model is likely an Intel CPU, where the AH1 model uses an AMD CPU.

I had BIOS 0301, and used flashrom to flash to 0801.  There is no 0801 for the AH1 model, but there is for the PH1 model.

Flashrom read my 0301 BIOS to a file, that matched the exact byte count of the 0801 BIOS I had downloaded and extracted as a BIN file.  I ran the flashrom -w with the 0801 BIN file, it wrote and verified and exited success.  I ran the -v and it re-verified success.  (I'm using instructions found at https://wiki.archlinux.org/index.php/Flashing_BIOS_from_Linux, including their reference to http://www.flashrom.org/Flashrom).

There was no indication of any kind of mismatch.

Since all those things were a success, I rebooted.  Got a black screen, with power LED on.  I shut down using front power button for a minute, turned on, got black screen, power LED on (no HDD activity).  System was willing to turn off using ten second "shutdown override."  I pulled the power cord for ten minutes:  Now, system fan comes on full power, power button did not do anything (no power LED).  Eventually I discovered that the ten second override would shut the fan off (never heard it go full blast before).

There is a red recessed small-object-only reset button at the top of the Pundit's front panel.  I could not change the basic No POST symptom with this, but I have not tracked down documentation on how to use it correctly (there's usually something about holding your mouth this way or that while pressing it).

Now I get a single flash from the HDD LED when I press the front power button, no power LED, and full power fan.  Shutdown override still works.

Identifying info:

Make:  Asus
Marketing model:  Pundit P1-AH1
Back sticker model:  AS P1-AH1 A8N8L
Serial number: 64P0AL018820
MB model:  A8N8L
Chipset: Nvidia MCP 51/Crush 51PV (AH1 manual page 54, MB block diagram)
Flash BIOS chip (I think):  PMC Flash
BIOS BIN file sizes:  All files are 524,288 bytes (512 KB)

Relevant links I used:

Discussion of MB model number versus system model name:


Page I accidentally got BIOS from:


Page I should have gotten BIOS from:


(latest BIOS for AH1 is 0402, not 0801)

I'm surprised I made this mistake, I've several decades experience maintaining personal computers.

You may share this e-mail with the public mailing list, but I prefer to be known as Jason-without-an-email-address.

If you have any suggestion what I can try next let me know.

The point of the exercise was to get support for the latest of the Socket 939 AMD CPUs.  This is a nice little living room system, very quiet.  I could not find the motherboard for sale on Google or eBay, nor the system for that matter; it dates to about 2006.  


Jason M.

More information about the flashrom mailing list