[flashrom] Asus P8P67 LE works, successfully wrote and verified

Stefan Tauner stefan.tauner at student.tuwien.ac.at
Sun May 12 01:15:24 CEST 2013

On Thu, 09 May 2013 03:35:51 -0430
artemis3 <artemis3 at cantv.net> wrote:

> Hello, I checked your wiki matrix, and I'm not sure i quite understand
> where it says "NO (42)" what exactly means.
> I have this motherboard, which is a B2. there is a B3 next to it in
> your hardware table with a green "OK" (P8P67 PRO). I went ahead and
> tried flashing anyway and it worked!, It could write and verify back
> an old bios (1104) downloaded from Asus page.

Great, thanks for telling us.

> This board was nearly bricked by the writing of a B3 bios which made
> all sort of trouble to it, after several attempts (wouldn't post) i
> managed to boot linux and went with flashrom.
> Note 42 has this written: "Probing works (Winbond W25Q32, 4096 kB,
> SPI), but parts of the flash are problematic: descriptor is r/o
> (conforming to ICH reqs), ME region is locked." But this is wrong,
> flashrom identified chip MX25L3205 like the other 2 previous models. I
> have no idea what this ME and ICH business is to deserve a red NO, but
> it worked with mine.

The previous report does indeed have a winbond chip in it:
I will contact the owner and try to find out his exact revision and
will change the table accordingly.

Please see our wiki for more information about the ME problem if you are
interested: http://flashrom.org/ME

> Asus page happily mentions "Pre-B3 revision motherboard users can also
> download and use the new B3 revision BIOS, drivers and utilities."
> http://event.asus.com/2011/mb/Identify_B3_Motherboards/
> That is absolutely wrong!, Pre B3 users can't use any B3 BIOS image!.
> In my case, the bios got all sensor values wrong, and it wanted to
> shutdown as it thought the processor was over/under temp, voltage etc,
> i managed to turn off all power setting things i could to be able to
> post, and the bios would often freeze requiring moving the clear
> jumper before even wanting to turn the power on again many times.
> I also learned something about Asus: while their BIOS EZ Flash tool
> happily allows upgrading to this dangerous B3 bios in a B2 board, it
> won't let you flash back to the older working version, genius move...

hehe I dont understand either why various manufacturers do this nonsense
since about forever...

> I used flashrom from the Ubuntu repository.
> flashrom v0.9.5.2-r1517 on Linux 3.5.0-28-generic (x86_64), built with
> libpci 3.1.8, GCC 4.6.3, little endian
> flashrom is free software, get the source code at http://www.flashrom.org
> Calibrating delay loop... OK.
> Found chipset "Intel P67". Enabling flash write... OK.
> Found Macronix flash chip "MX25L3205" (4096 kB, SPI) at physical
> address 0xffc00000.

Can you please send me the output of flashrom -p internal -VV too
and/or the output of dmidecode?
Kind regards/Mit freundlichen Grüßen, Stefan Tauner

More information about the flashrom mailing list