[flashrom] Intel QM67 - Macronix MX25L6405 flash read problem

Stefan Tauner stefan.tauner at student.tuwien.ac.at
Fri Mar 15 15:15:18 CET 2013

On Fri, 15 Mar 2013 15:56:28 +0200
George Ciobanu <mrg2k8 at gmail.com> wrote:

> I've tried to read the contents of the memory in the subject, but it
> failed. I'm using a Panasonic CF-53 Toughbook and I have attached the
> verbose output.

> 0x5C: 0x057f0003 FREG2: Warning: Management Engine region (0x00003000-0x0057ffff) is locked.

Hello George,

thanks for your report!

The problem is the locked ME region as quoted above. We are working on
unlocking it or working around it, but intel does not provide us any
documentation so please do not expect a solution soon (or ever).

> Do you think that I will be able to read the memory using serprog and an
> Arduino, unsoldering it from the motherboard or will flashrom just give the
> same error?

The problem is the configuration of the mainboard chipset. Outside of
the board flashrom will definitely be able to read and write the chip
(there is a minor problem of misdetecting the MX25L6405 because
Macronix used the same ID for different chips, but there is a patch for
that http://patchwork.coreboot.org/patch/3851/ and a quick hack that
you could apply locally is just a simple number change).

You might be able to access the flash chip while it is still soldered,
so that you do not need to desolder it (completely), see

If you need to read the BIOS region only, there is a complete
software-based solution too.
Kind regards/Mit freundlichen Grüßen, Stefan Tauner

More information about the flashrom mailing list