[flashrom] Trouble disabling write-protection on Chromebook

BM-2cWKH3wgq8zXX9eHfba16oTc8b61ead4Yq at bitmessage.ch BM-2cWKH3wgq8zXX9eHfba16oTc8b61ead4Yq at bitmessage.ch
Tue Dec 17 06:09:05 CET 2013

> On Mon, Dec 16, 2013 at 9:14 AM, <
> BM-2cWKH3wgq8zXX9eHfba16oTc8b61ead4Yq at bitmessage.ch> wrote:
>> Hello flashrom developers,
>> I'm having trouble disabling write-protection on my Samsung Arm
>> Chromebook. So far I've removed the metallic sticker covering the
>> "write-protect screw hole" according to the pictures on the Chromium
>> wiki
>> <
>> http://www.chromium.org/chromium-os/developer-information-for-chrome-os-devices/samsung-arm-chromebook
>> >.
>> On the Snow board, this hole ships with no screw in it.
> Are you sure about that? There should be a screw there...

I guess I should not have spoken for all Snow boards, but mine certainly
did not have a screw in the write-protect screw hole--only the metallic
sticker. I did notice this the first time I opened it up, but I wasn't
sure what to make of it.

>> As root in
>> developer mode, the output of flashrom -v is "flashrom v0.9.4  : 4169bc8
>> ...". The first time I ran flashrom --wp-disable, I got a message saying
>> the operation FAILED with error=1. At that point I took the board apart
>> again and cleaned the write-protect screw hole with q-tips dipped in
>> rubbing alcohol. When I reassembled the Chromebook and tried again with
>> flashrom -V --wp-disable, the last few lines I receive are:
>> w25_set_srp0: old status: 0xb8
>> w25_set_srp0: new status: 0xb8
>> w25q_disable_writeprotect(): error=1.
>> No -i argument is specified, set ignore_fmap.
>> restore_power_management(): Power management enabled
>> As you can see, I can't seem to disable write protection on this chip.
>> I'm
>> running stock ChromeOS. Any idea what I might be doing wrong? Thanks in
>> advance.
> That's weird... Since you have the system taken apart already, can you try
> disconnecting the battery while the machine is unplugged? I'd recommend
> leaving it disconnected for a minute or so, the idea being to give the SPI
> ROM enough time to fully discharge and reset.

Thanks for responding. I took your advice and disconnected the battery for
several minutes. After reassembling the board and running flashrom
--wp-disable again I am receiving the same message (FAILED). flashrom
--wp-status says:

WP: status: 0x00b8
WP: status.srp0: 1
WP: status.srp1: 0
WP: write protect is enabled.
WP: write protect range: start=0x00000000, len=0x00200000

> If you have a voltmeter handy, you can also try measuring the voltage on
> the /WP pin (pin 3). More details on pin configuration can be found in the
> datasheet:
> http://www.winbond-usa.com/hq/enu/ProductAndSales/ProductLines/FlashMemory/SerialFlash/W25Q32DW.htm

I don't have voltmeter; I'm sure I could locate one given enough time
though. Do you have any other suggestions as to steps I might be
overlooking here? Otherwise, what should I be looking for specifically in
the Winbond data sheet?

More information about the flashrom mailing list