[flashrom] [commit] r1732 - trunk

repository service svn at flashrom.org
Sat Aug 31 00:23:02 CEST 2013


Author: stefanct
Date: Sat Aug 31 00:23:02 2013
New Revision: 1732
URL: http://flashrom.org/trac/flashrom/changeset/1732

Log:
layout: Rename romlayout_t to romentry_t.

The type describes one entry of the whole layout actually.
Using layout_entry_t or something similar would be more correct,
but due to it length we will use "rom" instead of "layout" here and
in upcoming code.

Signed-off-by: Stefan Tauner <stefan.tauner at student.tuwien.ac.at>
Acked-by: Stefan Tauner <stefan.tauner at student.tuwien.ac.at>

Modified:
   trunk/layout.c

Modified: trunk/layout.c
==============================================================================
--- trunk/layout.c	Sat Aug 31 00:22:57 2013	(r1731)
+++ trunk/layout.c	Sat Aug 31 00:23:02 2013	(r1732)
@@ -32,10 +32,10 @@
 	unsigned int end;
 	unsigned int included;
 	char name[256];
-} romlayout_t;
+} romentry_t;
 
 /* rom_entries store the entries specified in a layout file and associated run-time data */
-static romlayout_t rom_entries[MAX_ROMLAYOUT];
+static romentry_t rom_entries[MAX_ROMLAYOUT];
 static int num_rom_entries = 0; /* the number of valid rom_entries */
 
 /* include_args holds the arguments specified at the command line with -i. They must be processed at some point
@@ -189,12 +189,12 @@
 	return 0;
 }
 
-romlayout_t *get_next_included_romentry(unsigned int start)
+romentry_t *get_next_included_romentry(unsigned int start)
 {
 	int i;
 	unsigned int best_start = UINT_MAX;
-	romlayout_t *best_entry = NULL;
-	romlayout_t *cur;
+	romentry_t *best_entry = NULL;
+	romentry_t *cur;
 
 	/* First come, first serve for overlapping regions. */
 	for (i = 0; i < num_rom_entries; i++) {
@@ -219,7 +219,7 @@
 int handle_romentries(const struct flashctx *flash, uint8_t *oldcontents, uint8_t *newcontents)
 {
 	unsigned int start = 0;
-	romlayout_t *entry;
+	romentry_t *entry;
 	unsigned int size = flash->chip->total_size * 1024;
 
 	/* If no regions were specified for inclusion, assume




More information about the flashrom mailing list