[flashrom] [PATCH] Clean up error code definitions

Stefan Tauner stefan.tauner at student.tuwien.ac.at
Thu Jan 12 02:15:04 CET 2012


i dont care much for the exact names, but i wish for a few things to be
 - all of them should have a common prefix. this is mostly a problem
   for the value of "OK". often projects use "ERR_" as prefix which
   leads to ERR_OK macros or similar, which isnt too bad. i would
   prefer that over having different prefixes. if we want a very short
   prefix ERR_ is probably best because most return values will be
   some error. but there is also OK and some warnings, so i would favor
   something more neutral like RET_ or so.
 - do we need a "flashrom" prefix too? iirc these are internal
   values so we can ignore external users, right? we may want to define
   some external values too then? could be postponed...
 - all of them should be somewhat readable in context and have
   approximately the same length.

Kind regards/Mit freundlichen Grüßen, Stefan Tauner

More information about the flashrom mailing list