[flashrom] [PATCH] Move show_id to where it belongs.

Stefan Tauner stefan.tauner at student.tuwien.ac.at
Sat Aug 11 18:09:45 CEST 2012

On Sat, 11 Aug 2012 17:12:27 +0200
Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006 at gmx.net> wrote:

> Am 11.08.2012 04:56 schrieb Stefan Tauner:
> > And remove the unused force parameter.
> >
> > Signed-off-by: Stefan Tauner <stefan.tauner at student.tuwien.ac.at>
> > ---
> > i forgot to move the declaration in the header, and i noticed that the
> > force parameter is useless because we use the global variable instead.
> > this should actually change eventually, but for now just kill the
> > parameter because it is doubtful that it will be part of the solution.
> Can you please rename show_id to check_image_matches_hardware or
> something like that (e.g. check_image_matches_cbtable_id)? show_id is a
> totally misleading name.
yes, indeed. i have changed it already locally and will post a huge
patch (set) including this soon-ish.

> AFAICS the rest is a pure code move, and makes a lot of sense.
it was already suggested in a comment, no idea why no one actually
moved it. it is really obvious in the current state.

> Oh, and please downgrade the following message to pdbg:
> msg_pinfo("Flash image seems to be a legacy BIOS. Disabling coreboot-related checks.\n");
> Maybe downgrade the following message as well:
> msg_pinfo("Flash image seems to have garbage in the ID location. Disabling checks.\n");
will do so in the upcoming patches because it is easier.

> Acked-by: Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006 at gmx.net>
committed in r1569.
Kind regards/Mit freundlichen Grüßen, Stefan Tauner

More information about the flashrom mailing list