[flashrom] Flashrom stuck using 100% cpu while probing for a chip

GatoLoko gatoloko at gmail.com
Fri Aug 10 16:34:47 CEST 2012

El 06/08/11 19:14, GatoLoko escribió:
> I've identified the chip as "Macronix MX25L4005APC-12G", so I tried the
> command "flashrom -c MX25L4005 -VVV" but I got the same result than before.

A year has passed, and i've tried again to see whether any of the fixes
done in the time being changed anything, but it still does the same thing.

$ sudo strace -o strace.log ./flashrom -c MX25L4005 -VVV --programmer
flashrom v0.9.6.1-r1567 on Linux 3.2.0-27-generic (x86_64)
flashrom is free software, get the source code at http://www.flashrom.org

flashrom was built with libpci 3.1.8, GCC 4.6.3, little endian
Command line (5 args): ./flashrom -c MX25L4005 -VVV --programmer internal
Calibrating delay loop... OS timer resolution is 2 usecs, 1194M loops
per second, 10 myus = 11 us, 100 myus = 101 us, 1000 myus = 1009 us,
10000 myus = 9997 us, 8 myus = 9 us, OK.
Initializing internal programmer
No coreboot table found.
DMI string system-manufacturer: "To Be Filled By O.E.M."
DMI string system-product-name: "To Be Filled By O.E.M."
DMI string system-version: "To Be Filled By O.E.M."
DMI string baseboard-manufacturer: "ASRock"
DMI string baseboard-product-name: "M3A-GLAN"
DMI string baseboard-version: "                      "
DMI string chassis-type: "Desktop"
Found chipset "AMD SB600" with PCI ID 1002:438d. Enabling flash write...
SPI base address is at 0xfec00100
AltSpiCSEnable=0, SpiRomEnable=0, AbortEnable=0
PrefetchEnSPIFromIMC=0, PrefetchEnSPIFromHost=0, SpiOpEnInLpcMode=0
SpiArbEnable=1, SpiAccessMacRomEn=1, SpiHostAccessRomEn=1,
ArbWaitCount=4, SpiBridgeDisable=0, DropOneClkOnRd=0
NormSpeed is 16.5 MHz
GPIO11 used for SPI_DO
GPIO12 used for SPI_DI
GPIO31 used for SPI_HOLD
GPIO32 used for SPI_CS
GPIO47 used for SPI_CLK
SB700 IMC is not active.
ROM strap override is not active
The following protocols are supported: LPC, FWH, SPI.
Probing for Macronix MX25L4005, 512 kB: sb600_spi_send_command, cmd=9f,
writecnt=0, readcnt=3
SB600 FIFO pointer is 0, wanted 0

And stops there until I kill it. But this time strace DID output a log.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: strace.log
Type: text/x-log
Size: 40041 bytes
Desc: not available
URL: <http://www.flashrom.org/pipermail/flashrom/attachments/20120810/64695c14/attachment.log>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 294 bytes
Desc: OpenPGP digital signature
URL: <http://www.flashrom.org/pipermail/flashrom/attachments/20120810/64695c14/attachment.asc>

More information about the flashrom mailing list