[flashrom] SUCCESS: MX25L1605 on Thinkpad X60s [was: FAILED]

Motiejus Jakštys desired.mta at gmail.com
Tue Apr 24 23:48:33 CEST 2012

On Tue, Apr 24, 2012 at 11:34:23PM +0200, Peter Stuge wrote:
> Motiejus Jakštys wrote:
> > Yes, it flashed fine. There is still a minor disturbance, though:
> > tp_smapi does not recognize my TP. But whatever, I can live with that.
> Could you send some logs showing this failure? I don't recall seeing
> it, but I also haven't actively tried to use tp_smapi on my machine.

# modprobe tp_smapi
FATAL: Error inserting tp_smapi
(/lib/modules/2.6.32-5-686/updates/dkms/tp_smapi.ko): No such device

and in dmesg:
[ 1833.552687] thinkpad_ec: no ThinkPad embedded controller!

According to ThinkWiki[1], I should upgrade my BIOS. I gave up here. I
wonder are there any gotchas if I run Linux as BIOS as a Payload? Quite
scary. It is so weird to think about a computer without BIOS.

> > > Now, there is also a possibility that coreboot can do something to
> > > work around this situation, similarly to what the factory BIOS
> > > obviously does, since the noise is not present there, but this has
> > > not been researched.
> > 
> > Probably power saving was disabled in original BIOS. I got this computer
> > used and somehow didn't check it, was too hurry to flash to coreboot.
> I somehow think the power saving has too big impact on battery life
> to have been disabled, but oh well.

Well, I can revert to my old bios and see what was there for real. Would
it make sense?

Besides, what exactly is your TP model?

> > > I'm glad to hear that it works for you!
> > 
> > Thanks a lot for your help. :)
> You're welcome, but thank Sven instead, he did the port and pointed
> out the flashrom trick! :)

Thanks Sven!

This community is awesome.


[1]: http://www.thinkwiki.org/wiki/Tp_smapi

More information about the flashrom mailing list