[flashrom] FAILED: GeForce6100PM-M2

Stefan Tauner stefan.tauner at student.tuwien.ac.at
Sun Oct 2 22:45:51 CEST 2011

this was fixed by retry (or so :), see below for the log of the IRC

* cupantae (~mark@*) has joined #flashrom
<cupantae> I tried to update my bios but now even the writing the backup gives an error. What can I do?
<cupantae> I have emailed flashrom at flashrom.org with the report
<idwer> first thing to not do is reboot, second thing is to upload the whole output to http://paste.flashrom.org
<cupantae> ok. done
<cupantae> i'm not sure if this is helpful, but at the "VERIFY FAILED", it gave a different reason each time
<cupantae> first it was at 0x000acd00! Expected=0x23, Read=0xff, failed byte count from 0x00000000-0x000fffff: 0xfe
<cupantae> then  at 0x00029400! Expected=0x12, Read=0xff, failed byte count from 0x00000000-0x000fffff: 0x1fc
<cupantae> then at 0x00067700! Expected=0x2f, Read=0xff, failed byte count from 0x00000000-0x000fffff: 0x4ea
<cupantae> oh wait, but always 0xff
<agaran> what machine it is
<cupantae> it's there in http://paste.flashrom.org
<cupantae> it's a geforce6100pm-m2
<agaran> video card?
<cupantae> no that's the name of the motherboard
<cupantae> named after the onboard graphics, it would seem
<agaran> hmm, i never tried upgrading bios on such combo board, but if on internal programmer you get changing reads its *WEIRD*
<agaran> cupantae: can you dump few times actual flash content to new file each time (and not overwriting first backup), then calc md5 over those and show us?
<cupantae> you mean with flashrom -r?
<agaran> yes
<cupantae> ok
<agaran> but please do not overwrite backup
<cupantae> ok. i'm starting "dump1"
<cupantae> without flashing the rom in between, the md5 stayed the same
<cupantae> 625ad915d91e7b134b48aef0105a640b
<cupantae> currently flashing again with the updated version of the bios
<agaran> so it fails on write but in different things
<agaran> so now it worked?
<cupantae> well, attempting to flash, i suppose i should say
<agaran> ok, so verification now against backup passes?
<cupantae> oh my god, it verified this time
<cupantae> i didn't change anything, so is it reasonable to be nervous about rebooting?
<agaran> so if you did backup and assuming read is always correct then i should its quite safe
<agaran> but still i would be somewhat uncertain why it failed at different addresses each time on verify
<cupantae> it does seem strange. that said, i'm not at all familiar with this stuff :-)
<agaran> it is strange
<cupantae> the output is the same before the verifying stage, btw
<cupantae> between the working and failing attempts
<cupantae> anyway, i suppose i don't need your help any more! thanks for your time
<cupantae> so will i reboot and tell you if it worked?
* cupantae has quit (Quit: rebooting)
* cupantae (~mark@*) has joined #flashrom
<cupantae> agaran: back on post-reboot.
<cupantae> seems like a fairly shitty "upgrade" but what harm :-P
<cupantae> thanks for all the support!
* cupantae has quit (Client Quit)

Kind regards/Mit freundlichen Grüßen, Stefan Tauner

More information about the flashrom mailing list