[flashrom] Error: Programmer initialization failed.

hann martin karenhann at blueyonder.co.uk
Fri Nov 26 15:56:16 CET 2010


I'm hoping you can help me.

My daughter was given a laptop that had suffered a disk crash (I also
suspect it had suffered a vicious virus).  I replaced the HDD but could not
get the damned machine to load windows from CD.  I tried everything and then
tried installing Ubuntu instead - worked first time - amazing!  Problem is
my daughter needs to use a specialist app which is not supported under Linux
so I need to get Windows on there somehow.
I suspected that the BIOS is corrupt as it just refuses to boot windows from
CD (tried 3 different copies) so thought I would try Flashrom.  I am not
particularly techie so am probably doing something stupid but this is what
happens when I try it ...

new at new-desktop:~$ sudo flashrom -r backup.bin
flashrom v0.9.1-r706
No coreboot table found.
Found chipset "Intel ICH4-M", enabling flash write... FAILED!
This chipset supports the following protocols: Non-SPI.
Error: Programmer initialization failed.
any help would be gratefully received.


Martin Hann
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.flashrom.org/pipermail/flashrom/attachments/20101126/853a825e/attachment.html>

More information about the flashrom mailing list