[flashrom] Help, please. :-)

Michael Karcher flashrom at mkarcher.dialup.fu-berlin.de
Thu Jul 22 09:33:09 CEST 2010

Am Mittwoch, den 21.07.2010, 22:19 -0400 schrieb Colin Williams:
> complained about not being able to erase, then said "SUCCESS" and
> "done", and "COMPLETE".
The output of flashrom is a bit confusing, cleaning that up is one of
the many pending tasks. Your flash chip has different erase methods, 
and if one fails, we try the next one. In your case, flashrom tried
erasing in blocks of 4K each, but the second 4K block was not erased. It
then tried to erase 32K each block, and failed in the first block. On
erasing in blocks of 64K, erasing 4 blocks went OK while it hit a
problem in the 5th block. Finally it tried a "chip erase" instruction
which worked. (this is the "SUCCESS" in your output). Then it sent write
instructions to the flash chip for all data bytes, after that it said
"COMPLETE". Finally on checking that the write was successfull, it finds
out that many write instructions in fact did not work.

For the erase instructions, I am surprised to find that every failed
erase instruction has "0xe9" as its first non-erased byte. Flashrom
checks the success of the erase by reading the to-be-erased region and
comparing it to the expect result of 0xff. What's also interesting is
that the failures are always on an address with the last five bits being
0x08. I suspect that something goes wrong with the communication between
the chipset and the flash chip (maybe some other flash accesses, for
example from System Management Mode?).

> and it now reports the chip as a "SST unknown SST SPI chip", with all
> four operations not working.  Attached are the output of the failed
> flash attempt, and a probe from after that attempt.
can you please send the output of "flashrom -VV" and "lspci -vvvnnxxx"
to the list, and send me privately the old backup image, the image you
tried to write and the file "contentsnow.bin" created by 'flashrom -r
contentsnow.bin -f -c SST49LF160C', and also check whether different
runs of flashrom create the same contentsnow.bin? It looks like flashrom
managed to mess up your chipset configuration that much that most flash
accesses do not do what they really should do anymore.

  Michael Karcher

More information about the flashrom mailing list