[flashrom] Problem with FLASHROM, results in error while updating BIOS. Please help me urgently..

Ajay Pai P: ajaypaip at gmail.com
Wed Jul 21 04:27:22 CEST 2010

Dear Sir,

I had troubles in booting my system (ASUS A8N-Vm motherboard with AMI BIOS)
ie. it would boot only every alternate times. So the first time I boot it,
the motherboard seems to run fine (with all the necessary lights on and the
cpu fan running) however there is no output on my monitor and the monitor
power led simply keeps blinking. All I have to do is shut it down once by
pressing the Power off/on button for long and then again switch on after
which it boots simply fine. It doesnt seem to be because of cold start
because even if i switch off my system after keeping it on for a long time,
and try to boot it immediately, I have to again follow this procedure.I got
my monitor tested and its fine. So i doubt my BIOS now. I tried updating it
with Flashrom as follows and it results in error:

$ sudo flashrom -w /media/BACKUP/Backups/OS\

flashrom v0.9.2-r1001 on Linux 2.6.31-ARCH (x86_64), built with libpci
3.1.7, GCC 4.5.0 20100520 (prerelease)
flashrom is free software, get the source code at http://www.flashrom.org

No coreboot table found.
Found chipset "NVIDIA MCP51", enabling flash write... OK.
This chipset supports the following protocols: Non-SPI.
Calibrating delay loop... OK.
Found chip "SST SST49LF004A/B" (512 KB, FWH) at physical address 0xfff80000.
Flash image seems to be a legacy BIOS. Disabling checks.
Writing flash chip... Erasing flash chip... ERASE FAILED at 0x00000008!
Expected=0xff, Read=0x90, failed byte count from 0x00000000-0x00000fff:
ERASE FAILED at 0x00000008! Expected=0xff, Read=0x90, failed byte count from
0x00000000-0x0000ffff: 0xfefe
Your flash chip is in an unknown state.
Get help on IRC at irc.freenode.net (channel #flashrom) or
mail flashrom at flashrom.org!

Now I am not able to decide what is to be done. I am not sure if I ran the
commands properly or if the BIOS chip is fine or not. I hereby request you
to please guide me and help me overcome this problem and get my PC running
fine. I shall be looking forward to your reply with crossed fingers.

Thanking you in advance.


Ajay Pai P
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.flashrom.org/pipermail/flashrom/attachments/20100721/30d22ecc/attachment.html>

More information about the flashrom mailing list