[flashrom] [PATCH] Make programmer_param static

Michael Karcher flashrom at mkarcher.dialup.fu-berlin.de
Thu Jul 8 11:05:42 CEST 2010

Am Donnerstag, den 08.07.2010, 10:36 +0200 schrieb Carl-Daniel
>  char *extract_param(char **haystack, char *needle, char *delim);
> +char *extract_programmer_param(char *needle);
Hmm. Is "needle" really a good name for the parameter anymore? I know
about the typical needle/haystack names in strstr, but for this specific
extract_programmer_param function, something like "name" or "key" might
make more sense. 

Anything else looks completely fine. You may or may not change the
parameter name at your option. I know our taste disagrees a bit on
identifier naming, so it's your patch, you decide. And having it named
needle like in the generic function makes some sense, too.

Acked-by: Michael Karcher <flashrom at mkarcher.dialup.fu-berlin.de>

  Michael Karcher

More information about the flashrom mailing list