[flashrom] Please help!

Michael Karcher flashrom at mkarcher.dialup.fu-berlin.de
Thu Jan 14 10:10:23 CET 2010

Am Mittwoch, den 13.01.2010, 21:28 -0500 schrieb Maxime Perron:
> Hi. I tried to flash my bios by I got these errors. What should I do?
> My mainboard is an MSI 865PE Neo2-P, chipset 6728v2. My previous bios
> was version 3.6. I tried to update to version 3.A
> Writing flash chip... ERASE FAILED at 0x000008c2! Expected=0xff,
> Read=0x19, failed byte count from 0x00000000-0x0000ffff: 0xf648
This looks like flashrom didn't manage to remove write protection on
your board and the BIOS chip contents is still unchanged. If you have a
backup of your old BIOS contents (created with flashrom -r), please run
'flashrom -v oldbackup.bin' and if it says 'VERIFIED' nothing changed
and it should be safe to reboot.

In that case, we need special code to support writing on your
mainboard. One of our developers will take a look at your report and
contact you once a patch is ready. This might take a few weeks because
we're all volunteers and the TODO list is rather big.

To help getting your board supported, please mail the output of
'flashrom -V', 'lspci -nnvvvxxx', 'superiotool -deV', 'dmidecode' (all
commands as root), the exact name of your board (including revision, if 
there are multiple revisions), and a link to the official BIOS download
to flashrom at flashrom.org . You might want to blank the serial
number/UUID/Asset Tag information in the dmidecode output for privacy
reasons. Please do not send BIOS images to the mailing list for
copyright reasons.

Installation instructions for superiotool can be found here:
Please use the svn version of superiotool if the package of your
distribution just says that it didn't find any super I/O chip.

Sorry for the delay in this reply.

  Michael Karcher

More information about the flashrom mailing list