[flashrom] [PATCH] Rename identifiers called 'byte'

Carl-Daniel Hailfinger c-d.hailfinger.devel.2006 at gmx.net
Thu Feb 25 12:03:47 CET 2010

On 25.02.2010 11:50, Michael Karcher wrote:
> Still fallout of adding "-Wshadow". Missed the ht1000 one
> (chipset_enable is not compied on Windows where we had the collision
> with "byte" last time) and the other occurrence is newly introduced.
> Old libpci defines a global symbol called "byte" too.
> Signed-off-by: Michael Karcher <flashrom at mkarcher.dialup.fu-berlin.de>

No objection from a technical POV, but I really dislike the name lpc_8a.
I don't have a good suggestion for a better variable name, though. Maybe
Oh well.

Acked-by: Carl-Daniel Hailfinger <c-d.hailfinger.devel.2006 at gmx.net>


"I do consider assignment statements and pointer variables to be among
computer science's most valuable treasures."
-- Donald E. Knuth

More information about the flashrom mailing list