[flashrom] Remarks on flashing ASUS M2N-E

Adrian Glaubitz adrian.glaubitz at googlemail.com
Fri Nov 6 16:41:57 CET 2009

Hi guys,

I have used flashrom (version 0.9.1+r736-1 from Debian testing) to
program the latest BIOS into my ASUS M2N-E mainboard. According to
flashrom, erasing and programming the BIOS chip was successful.
However, after rebooting the machine wouldn't fire up again. It
powered up but there was no sync signal on the VGA/DVI connector, also
no reaction to keyboard input. Fortunately, I could restore normal
operation by resetting the CMOS settings. The computer worked fine
again except that the hardware network address had changed to an
arbitrary value so that I couldn't connect to my local network at
first anymore. I think, however, that the MAC can be restored with the
AWDFLASH.EXE flash utility which has an option called "/MAC:" (haven't
tried yet, network works fine after matching the MAC on our local DHCP

Thus, it would be nice if you could update the entry in the flashrom
wiki with two footnotes on the ASUS M2N-E:

[1] If the machine doesn't come up again after flashing, try resetting the CMOS.
[2] Hardware address of the onboard network card might change to an
arbitrary value.

Especially [1] should be put as a footnote because despite the fact
that it is *always* recommended to reset your CMOS settings after
flashing a new BIOS version, the machine usually still comes up again
after flashing, prompting with something like "CMOS checksum error or
invalid settings".

I just want to provide flashrom users with as much information on
possible caveats as possible.



More information about the flashrom mailing list