[coreboot] Asus KGPE-D16 with latest coreboot errors with Unsupported Hardware on Qubes 4 install missing IOMMU?

petecb petecb at protonmail.com
Mon Dec 3 19:50:48 CET 2018


Hi Nico,

‐‐‐‐‐‐‐ Original Message ‐‐‐‐‐‐‐
On Sunday, December 2, 2018 10:30 PM, Nico Huber <nico.h at gmx.de> wrote:

> Hi Pete,
>
>
> did you have CONFIG_USE_OPTION_TABLE before? If not you potentially have
> changed all settings. The defaults in the cmos.default file don't have
> to be the same defaults that are hardcoded in the code and the file only
> takes effect if CONFIG_USE_OPTION_TABLE is set. As I looked at the SATA
> code, I know the AHCI setting is one that definitely differs.
>

No, I don't think I had CONFIG_USE_OPTION_TABLE before, so when I enabled the "Use CMOS for configuration values" I suspect it did change all sorts of settings.

>
> > I would value confirmation that it is safe to run the Crucial
> > CT16G3ERSLD4160B RAM I have in this board at 1.5v.
>
> Yes, all DDR3L should be 1.5V compatible. I'm fairly confused that such
> a board has a 1.35V option, though.
>
> Nico

Thank you for confirming 1.5V is ok, it's much appreciated.

Unfortunately I have had no joy in getting this system stable when I have enabled "Use CMOS for configuration values". I have tried it with and without the "Load default Configuration values into CMOS on each boot" option.
I have also used a range of permutations of the cmos.default file, beginning with the original default and extending to modifying some of the options Taiidan indicated worked fine for him (memory_speed_boost, 1394 controller and SATA ALPM).
I am flashing the BIOS with my beaglebone and am ensuring the CMOS is reset on the board before every boot with a new BIOS.
Each time it either resets halfway through booting Qubes (before getting to the disk unlock screen), or if I take my SSD out, it hangs in memtest after 3 or 4 seconds.

I am wondering if I have somehow selected some other incompatible option alongside the "Use CMOS for configuration values".
I have attached a text file with an overview of all the options I have selected with the nconfig utility, on the off-chance someone spots something I have done wrong. I have also attached the cmos.default file  in case it is helpful.

Kind regards,

Pete
-------------- next part --------------
A non-text attachment was scrubbed...
Name: AsusKGPE-D16nconfigSettings
Type: application/octet-stream
Size: 41554 bytes
Desc: not available
URL: <http://mail.coreboot.org/pipermail/coreboot/attachments/20181203/65b483aa/attachment.obj>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: cmos.default
Type: application/octet-stream
Size: 696 bytes
Desc: not available
URL: <http://mail.coreboot.org/pipermail/coreboot/attachments/20181203/65b483aa/attachment-0001.obj>


More information about the coreboot mailing list