[coreboot] ASUS P2-99 with P2B config

Branden Waldner scruffy99 at gmail.com
Mon Nov 20 01:43:27 CET 2017

Keith, I've attached the dmesg from running a build with the acpi
patch you had me listed as a reviewer on -

It's still throwing acpi errors. Is having color codes in the log
okay? I can avoid them in the future if it's a bother.

Also, I wouldn't really consider myself as qualified for reviewing
code, but I'll gladly test it.

As for getting flashrom working, I didn't get anywhere. I tried
writing eash of the piix gpos high and low and that didn't help,
though I did end up killing the fan by setting gpo0 low.

I actually flashed the asus p2b bios to it and the board booted and
ran fine. Flashrom still didn't work, but aflash still did. It doesn't
make sense, flashrom is supposed to work on the p2b and if there was
something needed for board enable on the p2-99 (and not p2b), then
aflash shouldn't work while running p2b bios. The boards look the same
though, the only differences I can find are the 440ZX northbridge, the
unpopulated third ram slot, and the lack of the hardware monitor chip
(fan and voltage).

I'd like to try putting together a dual flash, but the wiki seems a
bit lacking in details. It sounds like the idea is to connect vcc to
the chip enable pin with a switch and pull up resister, but doesn't
actually specify much. Is leaving the chip enable on the other other
flash chip floating okay or should it really be connected to ground?
(With another resister?) Is there a simple and cheap hardware setup to
switch this electronically for automated testing /.recovery? I
shouldn't have a problem with the soldering, I'd just like to know a
bit more about it before trying it. I'd prefer not killing the board
by screwing it up ( or messing up a hot swap). Even without flashrom
support, this would allow me to keep the asus bios on one chip and
coreboot on the other and just having the asus bios on one chip for
booting just to switch back and flash the other chip.

Anyway, back to the actual system. There's is a couple of quirks /
issues I need to look into yet.

When booting with only one ram stick, the keyboard doesn't work with
seabios and loading grub 2 from disk. This has happened otherwise
(with two ram sticks), but rarely. Even with the seabios keyboard
delay set really high (5000 milli seconds), it still doesn't work.
Linux has no problem once it's booted though.

Now for the really stange part, that got me to try removing a ram
stick in the first place. When rebooting from a uclibc hardened gentoo
(kernel 4.12) system and running memtest86+, it throws errors in
test(s) 3/4. This only happens after rebooting from that setup - not
debian stretch with linux 4.9 or 4.12bpo - and not after another
reboot. This happens with the debian, gentoo uclibc hardened, or
coreboot versions of memtest86+. This doesn't happen with the factory
bios. I tested this numerous times to verify what was happening -
marking down each test I ran..

Coreboot seems to setup the ram differently then the factory bios.
Memtest86+ lists the ram speed as 217MB/s (coreboot) vs 258MB/s
(bios), but with much better sysbench memory results with coreboot -
with the gentoo uclibc hardened setup with a 10 second test it got
double the bios did and with debian and sysbench memory set to 1600MB
(what the coreboot / gentoo uclibc hardened setup got in 10 seconds)
the debian it performed around four times better with coreboot vs
bios. And this is with passing eight couninous passes of memtest86+
when not running into the issue above. Is coreboot just using more
aggressive settings then the factory bios uses? I'm fine with coreboot
resulting in better performence then the factory bios!

Another note, several of the P2* board wiki pages list the L2 cache as
not working with coreboot. I ran into the L2 cache not working when I
originally tested this board with coreboot while running a pentium 2
at 400MHz. It seems that this was an issue with pentium 2 L2 cache
enablement, should the wiki document this as an issue with pentium 2
processsors? (specific versions?) The jumpers on the board were
actually set to 5.5 multiplier @ 100 MHz (like the current pentium iii
setup) and it didn't seem to have any affect - coreboot or bios. I
didn't do any benchmark tests though.

I also ended up testing the system with a pair of floppy drives, since
it's marked as untested on the p2b wiki page. Both worked fine with
the bios, but they didn't show up with seabios or after booting linux.
I don't particularly care about floppy support though, unless I wanted
to run it diskless and didn't have enough room on the flash for a
proper ipxe setup. PS/2 mouse works fine though - it is also marked

I guess that's it, I think I mentioned everything I was planning to.
I've got several things to look into and try to figure out. I also
have several other boards that have supported chipsets that might be
interesting to work on as well, but I should probably stick with this
one, for now, to try to get it sorted out better and to learn more
about about working with coreboot.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: p2-99_dmesg_acpi_review_color
Type: application/octet-stream
Size: 35336 bytes
Desc: not available
URL: <http://mail.coreboot.org/pipermail/coreboot/attachments/20171119/ad37ddea/attachment.obj>

More information about the coreboot mailing list