[coreboot] PS/2 Mouse on KGPE-D16

Paul Menzel paulepanter at users.sourceforge.net
Wed Mar 22 09:29:28 CET 2017

Dear cb,

Am Montag, den 20.03.2017, 21:15 +0000 schrieb cb at imap.cc:
> Has anybody had any success using a PS/2 mouse on the KGPE-D16?
> I tried a few PS/2 compatible USB mice, along with an adaptor, without
> success and thought that the mice might be to blame but I've just
> confirmed a native PS/2 mouse doesn't seem to work either.
> I've tried booting directly from SeaBIOS and also with GRUB2 as a
> secondary and no combination I try seems to work.

1.  Please attach all the relevant logs from coreboot, SeaBIOS, and the
Linux Kernel. Please also send us the configuration files of coreboot
and SeaBIOS.

2.  Could you please try passing `i8042.nopnp` to Linux on its command
line, and see if that changes anything?

3.  Lastly, could you please try another payload, which doesn’t rely on
ACPI. I think FreeDOS supports PS/2 mice, but I am not sure.


-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 195 bytes
Desc: This is a digitally signed message part
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20170322/26832ba5/attachment.asc>

More information about the coreboot mailing list