[coreboot] Asus P2-99: PS2 keyboard, time stamps, double logs

Branden Waldner scruffy99 at gmail.com
Sun Dec 17 00:41:54 CET 2017

Hi Paul,

My intention in uploading again to the board status repository was to
do to it with the patches Keith made merged. It's failed though as
make clean and make distclean didn't seem to clean up the old
(external?) acpi code like when I first tested the patch for Keith
(The kernel log shows acpi errors on lines 120 - 123). I might have
ended up just removing everything and running git reset --hard or
something last time to get it to work properly. I don't know how it
ended up not being marked as dirty then, but I figured to was still
okay to upload.

I wasn't sure yet what to do about the board mismatch. I think Keith
had recommended that I originally upload the board status as P2B to
insure that it was marked as being worked on so as not to be removed
by the upcoming coreboot release and clean up (that still hasn't
happened). Although it looks like the P2B and P2-99 use the same PCB
layout and my P2-99 having no problem with the P2B bios, without an
actual P2B to test with it might be best to treat them seperately.
That would basically mean that it would just be a straight copy of the
P2B to P2--99 for now and that the P2B would end up being removed as
not being tested recently.

Does anyone want to make a call on that to clean up the situation? Of
course, these boards are old and probably considered obsolete by alot
of people, so I don't know who would be interested in it.

As for the PS2 keyboard initialization, I had that set intending to
see if the I could avoid SeaBIOS failing to init the keyboard
occasionally. SeaBIOS throws "WARNING - Timeout at ps2_recvbyte:182!"
and then I can't use the keyboard with grub2 (on disk/ not coreboot
payload). I had tried setting a time-out with SeaBIOS before and it
seemed to have just ignored it. It seems to be more of a problem when
only having one ram stick, but all I have to do is hit the reset
switch and it usually works after rebooting. I guess I shouldn't have
had that set when uploading to board status, but alot of other entries
are marked dirty even, so I figured a weird set of options was fine. I
also wasn't really expecting a reply.

The time stamp collection not getting any output is because 'cbmem -t'
errors out with 'Could not open
/sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_max_freq: No such file or
directory'. I recall reading about other people having problems with
it and noted in one of my mails to Keith when testing the acpi patch
that I was having this issue, but don't know what to do about it. Does
cbmem actually need this, or why does it fail on it? It doesn't really
sound like something critical to it working. Is it part of the acpi
that didn't end up getting setup properly on this build?

As for the double boot log, yes, I did reboot before hand. I'd
forgotten about cbmem/board_status saving multiple boot logs then.

Thanks for the reply,


More information about the coreboot mailing list