[coreboot] Blank screen during boot and max CPU fan speed for ASUS KGPE-D16

Daniel K shambles_09 at hotmail.com
Wed Dec 6 09:12:33 CET 2017

Thanks for the suggestion about the RAM Zoran.

Tried it out in the following configurations for 2x CPU setup as per the ASUS documentation but with no luck:

- 8x 4 GB = 32 GB @ A2, B2, C2, D2, E2, F2, G2, H2

- 6x 4 GB = 24 GB @ A2, B2, C2, E2, F2, G2

- 4x 4 GB = 16 GB @ A2, C2, E2, G2

- 2x 4 GB = 8 GB @ A2, E2

Additionally, I find that my keyboard does not work in my SSD instance of GRUB (I have the default SeaBIOS on the coreboot BIOS chip) however after GRUB launches Debian, everything works fine.

Since coreboot is able to boot to my SSD, could it even be a RAM issue? I'd assume if there was an issue with the RAM the BIOS just wouldn't be able to proceed.

From: Zoran Stojsavljevic <zoran.stojsavljevic at gmail.com>
Sent: 05 December 2017 02:46
To: Daniel K
Cc: coreboot at coreboot.org
Subject: Re: [coreboot] Blank screen during boot and max CPU fan speed for ASUS KGPE-D16

> - Memory: 16x 4 GB = 64 GB Corsair DDR3-1600 SDRAM (CMZ32GX3M8X1600C9)

I will try shot in the dark, since I have no idea about AMD architecture. Seems that you have 8-memory channels architecture,
And being you I will start reducing amount of memory to see if anything changes. Would first do 8x 4GB and see what will happen with Coreboot?

Have no idea and original MRC algorithm (number of them) in BIOS is/are the same as in Coreboot... And I am trying to target the differences!

LRDIMMs, RDIMMs, and Supermicro’s Latest Twi - AnandTech<https://www.anandtech.com/show/6068/lrdimms-rdimms-supermicros-latest-twin/2>
Typically, desktop and mobile systems use Unbuffered DIMMs (UDIMMs). The memory controller inside your CPU addresses each memory chip of your UDIMM individually and ...


On Tue, Dec 5, 2017 at 8:05 AM, Daniel K <shambles_09 at hotmail.com<mailto:shambles_09 at hotmail.com>> wrote:


I'm trying out coreboot for the first time. This is great work you are all doing.

Having a few issues with my ASUS KGPE-D16 and wonder if anyone could help.

The issue is that my CPU fans appear to spin at maximum speed at all times, and the whole boot process is black until my Debian login screen.

Flash method:

Flashing a couple of 25Q16BVAIG DIP8 chips with a CH341A external USB programmer I bought online and the flashrom linux tool.

Using a chip extraction tool for the swap, and making sure to clear my CMOS memory between each swap.

Image creation:

Followed the steps from: https://www.coreboot.org/Build_HOWTO

I checked out the commit reported at the latest successful run: https://review.coreboot.org/gitweb/cgit/coreboot.git/commit/?id=3f09b0ffef990286ecca344cf73023b35be42406

For the .config file, I tried both creating my own with 'make nconfig' and also copied the .config from the latest successful run at: https://review.coreboot.org/gitweb/cgit/board-status.git/tree/asus/kgpe-d16/4.6-1125-g3f09b0f/2017-08-21T04_40_02Z/config.txt

I don't bother getting the AMD IMC, AMD XHCI, and AMD PSP because I don't believe my motherboard needs it according to the board page: https://www.coreboot.org/Board:asus/kgpe-d16

I also don't bother getting the vgabios.rom because according to https://www.phoronix.com/scan.php?page=news_item&px=NzQwMQ, coreboot has native vga text-mode? And this page states only text-mode works for my CPU: https://www.raptorengineering.com/coreboot/kgpe-d16-status.php

Detailed issue description:

In all instances, my PC boots up and shows a black screen for about 10-20 seconds.

About 5-10 seconds in, my CPU fans start blowing at what appears to be maximum speed.

After another 5-15 seconds, I see my Debian login screen and am able to use my computer normally.

However the loud fans put me on edge and I end up turning the PC off after a while.

At subsequent boots, the fans start up at maximum speed right away.

Swapping back to my vendor BIOS brings the fans back to normal. Could this be microcode related?

Same happens for both my onboard graphics as well as my PCIe GPU.

System specifications:

- Motherboard: ASUS KGPE-D16

- CPU: 2x AMD Opteron 6272 (2.1 GHz)

- Memory: 16x 4 GB = 64 GB Corsair DDR3-1600 SDRAM (CMZ32GX3M8X1600C9)

- Video: EVGA GeForce GTX 570 (128MB)

- Storage: Don't know if this matters, but I have 1x SSD and 1x HDD SATA 3 drives, and one PCIe M.2 NVMe adapter with an M.2 SSD.

Additional notes:

- Also tried the latest KGPE-D16 Libreboot image but I only get a permanent black screen with that.

- Disconnected the ASMB4/KVM module.

- Don't think I have LRDIMM RAM because I'm able to boot into Debian.


- Daniel K.

coreboot mailing list: coreboot at coreboot.org<mailto:coreboot at coreboot.org>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mail.coreboot.org/pipermail/coreboot/attachments/20171206/6bd4d6c3/attachment.html>

More information about the coreboot mailing list