[coreboot] Weird issue: payloads not showing after seabios

Charlotte Plusplus pluspluscharlotte at gmail.com
Mon Nov 7 22:24:26 CET 2016


I am sorry if this is a total noob question, but I can't get any other
payload to show other that the default seabios payload or memtest86.

nvramcui, tint, coreinfo (all automatically added by coreboot as secondary
payloads) or grub (added manually with cbfstool) show nothing, or cause a

I first thought that was due to my ram issues, but even after finding low
DDR3 that works reliably in coreboot, I still can't get other payloads.

Just to be sure I tried everything:
 - I used CONFIG_MAINBOARD_DO_NATIVE_VGA_INIT: weird font (maybe because I
have a FHD 1680x1080 screen instead of some different hardcoded resolution)
 - I tried CONFIG_VGA_ROM_RUN: garbled screen with wavy lines

I am back to none of these options, and a VGA rom initialized by Seabios. I
am using version 1.9.3 and the current coreboot head. I am now trying with
seabios 1.10  (d7adf6044a4c772b497e97272adf97426b34a249)

I have read https://www.coreboot.org/SeaBIOS#coreboot. I use at the moment
the .config attached, but I don't understand what is happening. I don't
have debug output yet, I just ordered a FT232H, as it was far less
expansive than a BBB. It will only arrive next week.

I think at least something should show on the screen when I press Esc and
select another payload. Only memtest86 works at the moment.

I am making some stupid mistake??

$ cat /opt/coreboot/blobs/payloads/seabios-minime.config
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20161107/1804659d/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: w520-reliable.config
Type: application/xml
Size: 20320 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20161107/1804659d/attachment.wsdl>

More information about the coreboot mailing list