[coreboot] [Intel Atom C2000 Rangeley] SPI Descriptor issue related to coreboot

WANG FEI wangfei.jimei at gmail.com
Wed Mar 18 23:04:28 CET 2015

Guo Jia,

It's not easy to figure out the problem in your case, it would be great if
you can have an ITP hooked on your system to debug coreboot instead of

I'm glad you've tried to dump descriptor bin from ADI's binary, but I
remember even without descriptor binary, Mohon Peak platform can still boot
up. I would suggest you checking the microcode, making sure the processor
revision matching the microcode included in coreboot, system will halt
itself If they does not match.


On Wed, Mar 18, 2015 at 2:17 AM, 郭佳 <yunyuaner at gmail.com> wrote:

> Hi buddies,
> I'm porting coreboot to Intel Atom C2000 board provided from ADI.
> I've retrieved the source code released by ADI from github.
> ADI's coreboot source code requires SegaBIOS SDK to build, since I
> don't have one, I've modified the Makefile to use toolchain provided by
> original coreboot(xgcc).
> When building done, there is a coreboot.rom(8M) under coreboot/build
> directory, and flashing this file to boot rom doesn't bring the system up,
> even no serial outputs.
> I found that there is no descriptor segment at the beginning of
> coreboot.rom.
> And in Makefile, there are following lines:
> "dd
> if=../intel/mainboard/intel/mohon_peak/unlocked_descriptor/descriptor.bin
> of=
> build/coreboot.pre conv=notrunc > /dev/null 2>&1;"
> Unfortunately, ADI doesn't release descriptor.bin.
> So, I use ifdtool to dump the descriptor from ADI's coreboot binary file.
> Firstly, I unlock the descriptor, then extract descriptor.bin, and
> after that, reassembly
> my own coreboot.rom file, but still fail to bring system up (no serial
> output,
> cpu core seems to fall into some infinite loop, when debugging with
> SourcePoint)
> I don't know if I've made my question clear, I'm new to x86/coreboot.
> Can someone help me? Thank you in advance.
> Regards,
> Hook Guo
> --
> coreboot mailing list: coreboot at coreboot.org
> http://www.coreboot.org/mailman/listinfo/coreboot
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20150318/6ae128b2/attachment.html>

More information about the coreboot mailing list