[coreboot] Tianocore boot fails, [GSoc] CBFS support in tiano - discussion (C Ganesh Sundar)

107112017 at nitt.edu 107112017 at nitt.edu
Thu Mar 12 20:23:55 CET 2015


I tried booting ELILO (disk.img - in gpt), ubuntu & windows 8(iso) on QEMU
but wasn't successful. I am able to boot into serial uefi shell only(a
blank fully black screen). I tried std vga ROM in QEMU too but no result.
Any comments/help would be grateful. Below is the serial output:

  BlockSize : 2048
  LastBlock : 1E9AF3
  BlockSize : 2048
  LastBlock : 7
  BlockSize : 2048
  LastBlock : 1E9539
Boot Failed. EFI DVD/CDROM
Memory  Previous  Current    Next
  Type    Pages     Pages     Pages
======  ========  ========  ========
   0A    00000004  00000002  00000004
   09    00000008  00000002  00000008
   00    00000004  00000000  00000004
   06    00000065  00000051  00000065
   05    00000030  0000002D  00000030
   03    00000180  00000170  00000180
   04    00000F00  000007C2  00000F00
Booting EFI Internal Shell
InstallProtocolInterface: 5B1B31A1-9562-11D2-8E3F-00A0C969723B 78064A8
Loading driver at 0x00006B0E000 EntryPoint=0x00006B0E240 Shell.efi

I want to try creating CBFS support in tianocore by writing a UEFI DXE Driver.
Since the ROM's address will be known, raw access of memory  
corresponding to the
ROM could be done and parsing functions provided. For CBFS located elsewhere a
base address could be provided as an argument. Existing cbfstool's  
code could be
used. I would like to know if this is a correct approach.

Thanking You!

More information about the coreboot mailing list