[coreboot] Mohon Peak, Memtest86+ does not start

Kuzmichev Viktor kuzmichevviktorv at gmail.com
Tue Jan 20 14:31:03 CET 2015


I'm trying to load Memtest86+ on the Mohon Peak reference board from 
CBFS and it fails.
My primary payload is SeaBIOS. Memtest is added using cbfstool, so the 
layout of my ROM file is as follows:

$ ./build/cbfstool build/coreboot.rom print
coreboot.rom: 8192 kB, bootblocksize 1024, romsize 8388608, offset 0x600000
alignment: 64 bytes, architecture: x86

Name                           Offset     Type         Size
cmos_layout.bin                0x600000   cmos_layout  1352
fallback/romstage              0x600580   stage        26616
fallback/ramstage              0x606dc0   stage        60446
fallback/payload               0x615a40   payload      55799
config                         0x623480   raw          4323
revision                       0x6245c0   raw          714
img/Memtest86+                 0x6248c0   payload      225028
(empty)                        0x65b800   null         1001368
mrc.cache                      0x74ffc0   (unknown)    65536
cpu_microcode_blob.bin         0x760000   microcode    83968
(empty)                        0x774840   null         46936
fsp.bin                        0x77ffc0   (unknown)    372736
(empty)                        0x7db000   null         150424

I've tried versions 4.20 and 5.01. Memtest86+ v4.20 just hangs, here is 
output of SeaBIOS trying to load it:
Trying CBFS
Booting from CBFS...
Run img/Memtest86+
Segment 41544144 194420 at 0xffe24920 -> 194420 at 0x00000000
No compression

And then nothing. Memtest86+ v5.01 goes a bit further, SeaBIOS finds its 
entry point:
Trying CBFS
Booting from CBFS...
Run img/Memtest86+
Segment 41544144 224972 at 0xffe24920 -> 224972 at 0x00000000
No compression
Calling addr 0x00010000

But after this the board reboots.
I also tried to load Memtest from HDD using Grub and v4.20 seems to work 
fine, while v5.01 causing reboot just like in case with CBFS.
And I also tried to add Memtest as a primary payload without SeaBIOS. 
Again, v5.01 causes reboot. And v4.20 cannot find linuxbios tables.


More information about the coreboot mailing list