[coreboot] Chromebox debugging.

Timothy Potter timothy.e.potter at gmail.com
Fri Jan 31 10:03:59 CET 2014

Hi Kyosti,
   Sorry, I reread your first reply and it became clear what you meant when
looking on the Chomebox's /var/log directory.  I found the port at the back
corner of the Chromebox is numbered  2-1.2.  None of the external ports
connect as 1-1.2.  Connecting the phone with the EHCI debug device enabled
kernel to the 2-1.2 port and booting Ubuntu on the Chromebox I see the
following in kmesg:

[    2.008799] usb 2-1.2: new high-speed USB device number 3 using ehci_hcd

[    2.031628] atkbd serio0: atkbd: SETLEDS failed

[    2.049059] init: plymouth main process (93) killed by ABRT signal

[    2.049409] init: plymouth-splash main process (398) terminated with
status 2

[    2.094946] usb 2-1.2: unable to read config index 0 descriptor/start:

[    2.097301] usb 2-1.2: chopping to 0 config(s)

[    2.099611] usb 2-1.2: New USB device found, idVendor=0525,

[    2.099615] usb 2-1.2: New USB device strings: Mfr=0, Product=0,

[    2.100136] usb 2-1.2: no configuration chosen from 0 choices

I can post the full logs if needed but they are quite long.

I tried different values for CONFIG_USBDEBUG_HCD_INDEX on the Coreboot
build.  I tried values of 0,1 & 2 but still didn't see any output on the
EHCI debug device with 'cat /dev/ttyGS0'


On Fri, Jan 24, 2014 at 4:41 PM, Kyösti Mälkki <kyosti.malkki at gmail.com>wrote:

> On 01/24/2014 12:18 PM, Timothy Potter wrote:
>> Sorry for not including all you asked for Kyösti,  I've not had much time
>> to spend on this.  So you are saying if lsusb -v reports a 'Debug
>> descriptor' I should be able to use that port as the EHCI debug port on
>> the
>> target?
> Hi
> I think my first reply was quite clear on what information I need to
> assist you solve it. But I am too close to see if some obvious details from
> my instructions were missing.
> This is more easily solved if you come to discuss on #coreboot. You should
> then write a tutorial for our wiki or at least reply here with the steps
> were you went wrong the first time.
> Kyösti
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20140131/3207b444/attachment.html>

More information about the coreboot mailing list