[coreboot] Chromebox debugging.

Timothy Potter timothy.e.potter at gmail.com
Fri Jan 24 00:39:20 CET 2014

Hi Kyosti,   Thanks the pointers.  I tried adding the changes for dbgp from
the bug20-2.6.35-linaro to the 2.6.32 kernel I'm running on the phone.  You
can see the results here:


On startup, in /proc/kmsg I see:

<7>[    2.010284] dbgp gadget: setup: desc device
<7>[    2.010314] dbgp gadget: setup complete: 0, 8/8
<7>[    2.010467] dbgp gadget: setup: desc device
<7>[    2.010467] dbgp gadget: setup complete: 0, 18/18
<7>[    2.010589] dbgp gadget: setup: failure req 6 v 200
<7>[    2.010681] dbgp gadget: setup: failure req 6 v 200
<7>[    2.010772] dbgp gadget: setup: failure req 6 v 200
<7>[    2.016204] dbgp gadget: setup: failure req 6 v 3ee

I've attached the full log in case there's more clues as to why it's
failing.  Any more suggestions of what I should be looking at?


On Mon, Jan 20, 2014 at 7:04 PM, Kyösti Mälkki <kyosti.malkki at gmail.com>wrote:

> On 01/20/2014 01:42 PM, Timothy Potter wrote:
>> On Sat, Jan 18, 2014 at 12:52 AM, John Lewis wrote:
>>> On 17/01/14 11:01, Timothy Potter wrote:
>>>>   I've
>>>> also got an old Android phone with the ECHI debug gadget compiled into
>>>> the kernel. I've tried connecting that to every USB port on the
>>>> Chromebox but never get any output.
>>>>  Hi Tim,
>>> Have you got "USB 2.0 EHCI debug dongle support" compiled on the
>>> coreboot side? If so, did you select "NET20DC and compatible" or
>>> "BeagleBone"?
>>> What kernel is the phone running? I assume because you have the EHCI
>>> debug gadget complied in the Android gadget is not? How does your phone
>>> react to the missing Android gadget?
>>>  Hi John,
>>    I had a bit of time to review what how I'd set things up this weekend.
>>   Yes. I compiled the debug dongle support into Coreboot, and left the
>> default 'NET20DC and compatible' selected.
>>    On the phone side. Yes, the EHCI debug gadget replaces the Android
>> gadget, so the phone won't even charge while booted, but otherwise seems
>> to
>> work as normal minus USB functionality. The kernel is version 2.6.32.  I
>> suspect the problem is on the phone side as the phone doesn't show up in
>> the output of lsusb when connected to a Linux box.
>>    I saw your video with the BeagleBone and HP laptop.  Thanks for making
>> it.  Good to see how things should work.
>> Tim.
> Hi Tim
> That kernel is missing some bits from USB gadget framework. The oldest we
> have some result for is 2.6.35 and even that requires some backported
> patches.
> We have this linked at bottom of coreboot EHCI gadget wiki:
> https://github.com/buglabs/bug20-2.6.35-linaro/commits/master
> Kyösti
> --
> coreboot mailing list: coreboot at coreboot.org
> http://www.coreboot.org/mailman/listinfo/coreboot
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20140124/f5da6df0/attachment-0001.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: kmsg.1
Type: application/octet-stream
Size: 42010 bytes
Desc: not available
URL: <http://www.coreboot.org/pipermail/coreboot/attachments/20140124/f5da6df0/attachment-0001.obj>

More information about the coreboot mailing list