[coreboot] ATTN: ruik, others: f2a85-m frequently crashes/freezes under high load. do you have it working?

Rudolf Marek r.marek at assembler.cz
Sat Jan 18 23:16:17 CET 2014

Hi Andrew,
> ruik, do you have a working setup with a f2a85-m motherboard at the
> moment (i.e. .config file, graphics card, distro/kernel version being
> used?) if nothing is working for you right now, how can we narrow this down?

Yes it seems it is working fine.

You can check http://www.coreboot.org/Supported_Motherboards

Or check:


Note that I'm using 1.65V for DDR3 memory. Please check your memory voltage in 
original bios if it is 1.5V or 1.65V. From what I seen in the longs it seems 
something dies in kernel, maybe interrupts or timer. Could be some unfixed 
errata. I run memtester in userspace today and I seen one mem problem (on 1.65V mem)

I use some Linux Mint, but mostly I just boot with this kernel.


> to anyone else: do you find that using one graphics card with coreboot,
> works while others do not? any ideas on how i can resolve this issue?

I don't have any recent external graphics card. I only use internal one with 
this board. I want to use it as my next workstation, I did not do any longrun 
testing yet.

> the problems i've been seeing are quite reliable. they happen when using
> coreboot + one of a couple graphics card models i've tried + extended
> high disk i/o, all together. at other times, these issues are more rare.
> also, a somewhat older compilation of coreboot with a vga_bios and
> without an external graphics card is crashing multiple times per day,
> during that person's day-to-day work flow.

Hm strange I have not seen any crashes like this.

> i would like to get coreboot with this motherboard working, so more
> people here can use it. :)

Yep great!

> my guess is that this is an issue with option roms playing nasty with
> coreboot, and that this issue is for some reason brought forth by the
> high i/o test. if any of those factors are absent, crashes are far less
> frequent, if at all.
> - - - - - - - - -
> i've been seeing crashing with f2a85-m motherboards with an a8-5600k
> processor. vga bioses have not been compiled in to coreboot.

My CPU is also 0x00610f01 but it is AMD A4-5300 APU with Radeon(tm) HD Graphics.

> kernel-loading of recent amd microcode has not solved the problem.
> option roms get loaded by seabios (

> the stress test i've been using is mostly running badblocks on repeat
> using a couple sata drives. the other test has been building four
> kernels at once.

Can you share the scripts? I tried today reading with DD on two harddrives and 
it was fine.

> if anyone has any idea of what the issue(s) may be here, or how i could
> try narrowing this down, please help me out. thanks! :)

It could be some unfixed errata.


I think I need to reproduce the problem first. I seen some PM_timer problem. 
What is your clocksource?

cat /sys/devices/system/clocksource/clocksource0/current_clocksource

I also seen some errata about USB3.0 controllers. Can you exclude usage of USB 3.0?

If you run memtester under Linux it is oK?


> -andrew

More information about the coreboot mailing list