[coreboot] #201: Error building coreboot for Samsung Exynos5 Google Snow

coreboot svn at coreboot.org
Thu Feb 27 00:03:00 CET 2014

#201: Error building coreboot for Samsung Exynos5 Google Snow
    Reporter:  Pete <bluestore.logmein@…>  |         Owner:  stepan@…
        Type:  defect                      |        Status:  new
    Priority:  major                       |     Milestone:
   Component:  coreboot                    |      Keywords:
Dependencies:                              |  Patch Status:  there is no
                                           |  patch

 I am trying to compile a coreboot rom for the Samsung chromebook Series 3
 - Exynos5, i followed the instructions at http://www.coreboot.org/Exynos5
 to compile the armv7a-eabi toolchain and evertyhing went ok. At the
 menuconfig i selected Google MainBoard, model Snow, exit and save. It
 starts to compile until it returns this error:
     GEN        generated/romstage.ld
     LINK       cbfs/fallback/romstage.debug
 build/ec/google/chromeec/ec.romstage.o: In function
 /home/suporte/coreboot/src/ec/google/chromeec/ec.c:117: undefined
 reference to `recovery_mode_enabled'
 collect2: error: ld returned 1 exit status
 make: *** [build/cbfs/fallback/romstage.debug] Error 1

 Am i missing something?

 Also tried make clean and make crossgcc, and even the built went fine,
 when i run make always returns this error.
 Thank you, Pete

Ticket URL: <https://tracker.coreboot.org/trac/coreboot/ticket/201>
coreboot <http://www.coreboot.org/>

More information about the coreboot mailing list