[coreboot] Fwd: IMB-A180E H coreboot won't boot (new)

Wim Vervoorn wvervoorn at eltan.com
Fri Feb 14 09:46:46 CET 2014

Hello Mark,

Have you tried using a slower SODIMM yet? I have seen issues here myself that were caused by the faster especially dual rank SODIMMs.

The easy solution is to simply use a slower or single rank SODIMM. The real solution is to manipulate the AGESA code for correct initialization of the memory controller.

Best Regards,

Wim Vervoorn
Eltan B.V.

-----Original Message-----
From: coreboot-bounces at coreboot.org [mailto:coreboot-bounces at coreboot.org] On Behalf Of Mark C. Mason
Sent: Thursday, February 13, 2014 6:59 PM
To: coreboot at coreboot.org
Subject: [coreboot] Fwd: IMB-A180E H coreboot won't boot (new)

I'm new to coreboot, and I'm working to use it with an ASROCK IMB-A180, the H version with the LVDS port.

I've read previous posts regarding the "IMB-A180 won't boot" on this group, and tried the .config that was posted, but the result is the same.

The debugging output shows things progressing until agesawwrapper_amdinitmid is called, then the boot restarts, then stops cold at the same point:

          PCI: 00:18.4
          PCI: 00:18.5
       Done allocating resources.
       BS: BS_DEV_RESOURCES times (us): entry 0 run 1095130 exit 0
       POST: 0x74
       Enabling resources...

       Fam16 - domain_enable_resources: AmdInitMid.
<garbage characters>     Tue Feb 4     16:46:38 PST
2014 starting...

Any help with this would be greatly appreciated.  Full serial debug output and .config are attached below.

Best regards,

Mark Mason
Engineering Design Team

More information about the coreboot mailing list